Opened 12 years ago

Closed 12 years ago

Last modified 11 months ago

#3222 closed defect (fixed)

GUI: Classic themes need to be updated

Reported by: eriktorbjorn Owned by: sev-
Priority: blocker Component: GUI
Keywords: Cc:
Game:

Description

Latest ScummVM SVN snapshot

(sev told me to put all of these in the same bug report)

If I select the "Classic (ScummVM 0.8.0)" theme, ScummVM warns me that "Theme config uses a different version (you have: '19', needed is: '21')

If I use the --gui-theme=classic command-line option, ScummVM warns that "Config 'classic' is NOT usable for themes or not found!"

Also, I could have sworn that if I selected the "Classic (Builtin)" theme, the Options dialog didn't have a "Misc" tab any more, but I can't reproduce it now. Sunday morning blindness, perhaps?

Ticket imported from: #1730147. Ticket imported from: bugs/3222.

Change History (3)

comment:1 by sev-, 12 years ago

Resolution: fixed
Status: newclosed

comment:2 by sev-, 12 years ago

1. Classic 0.8.0 theme has been updated to modern level
2. It appeared that it expected 'classic (builtin)' as a theme name, which is not very nice. So I added 'classic' alias to it,
3. I suppose you clicked on 'Edit Game...' button which doesn't have Misc tab. Misc tab is added to global options dialog unconditionally.

Thank you for reporting.

comment:3 by digitall, 11 months ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.