Opened 12 years ago

Closed 12 years ago

#3202 closed defect (fixed)

PUTTPUTT1 + 2: Lockup after HE/Game Intro

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Putt-Putt Joins the Parade

Description

ScummVM 0.10.0svn (May 24 2007 09:47:07)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

"PuttPutt joins the Parade" locks up after the HE logo was shown.
PuttPutt finishes his sentence "I'm ready to go" and leaves the
the screen to the right. That is where it locks up.

(3DO/english)

gcc version 4.0.2 (AmigaOS build 20051012)
AmigaOS4

-d9 log attached

Ticket imported from: #1724713. Ticket imported from: bugs/3202.

Attachments (3)

puttputtparade.zip (79.7 KB ) - added by SF/*anonymous 12 years ago.
-d9 log
PP1.zip (6.2 KB ) - added by SF/*anonymous 12 years ago.
Putt-Putt 1 Crashlog
PP2.zip (5.3 KB ) - added by SF/*anonymous 12 years ago.
Actually PP2 crashed SDL, not scummvm, but the error looks similar

Download all attachments as: .zip

Change History (15)

by SF/*anonymous, 12 years ago

Attachment: puttputtparade.zip added

-d9 log

comment:1 by sev-, 12 years ago

Weird, can't reproduce it here. Another Amiga-specific bug?

comment:2 by (none), 12 years ago

> Weird, can't reproduce it here. Another Amiga-specific bug?

<sigh>

If i could only understand C/C++

If i'm lucky this is the same that keeps locking up Simon1

comment:3 by (none), 12 years ago

Summary: PUTTPUTT1: Lockup after HE IntroPUTTPUTT1 + 2: Lockup after HE/Game Intro

comment:4 by (none), 12 years ago

For the sake of completion, it happens too in
PuttPutt 2: PuttPutt goes ot the Moon as soon
as the game is done with the intro and gives
the turn to the player (or so i think)
Not sure about that as i can't remember
when players turn start in PuttPutt1, but
definietely after the intro in PuttPutt2.

It's both version 5 of the Scumm engine, isn't it?
I tested the v5 games Monkey Island 1 (CDRom),
MI2 and Indy 4 (CDRom) and all run well, although
i don't know for sure if they are v5, too.

One of the mods may adapt the title of the report

comment:5 by sev-, 12 years ago

No, they are HE61 version. See engines/scumm/he/script_v60he.cpp

comment:6 by sev-, 12 years ago

No, they are HE61 version. See engines/scumm/he/script_v60he.cpp

comment:7 by Kirben, 12 years ago

Did the 3DO versions of HE games work in the previous ScummVM 0.9.1 release under AmigaOS4? is this actually a regression?

comment:8 by (none), 12 years ago

It is a regression, but not from 0.9.1.
It refuses to run in 0.9.1 also

With a CVS version i have (0.8.0 Oct 15 2005 16:53:50)
they run without locking up.

Sorry again to come up with it that late, but i don't
play or try them often and thought with the SVN version
having problems that it may go away eventually.

by SF/*anonymous, 12 years ago

Attachment: PP1.zip added

Putt-Putt 1 Crashlog

comment:9 by (none), 12 years ago

ScummVM 0.11.0svn (Oct 13 2007 22:12:06)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

With the aforementioned version i get no longer a silent
lockup but a (hopefully) useable crashlog.
File Added: PP1.zip

by SF/*anonymous, 12 years ago

Attachment: PP2.zip added

Actually PP2 crashed SDL, not scummvm, but the error looks similar

comment:10 by (none), 12 years ago

File Added: PP2.zip

comment:11 by raziel-, 12 years ago

Fixed entirely with one of the last commits
(can't pinpoint it, sorry)

As you can see from the record of this bugreport it was
fixed in small steps getting better with every commit :-)

Good work, thanks a lot

comment:12 by sev-, 12 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.