Opened 12 years ago

Closed 12 years ago

Last modified 11 months ago

#3185 closed defect (fixed)

WINCE: svn build startup crash

Reported by: SF/qwertypippo Owned by: SF/knakos
Priority: low Component: Port: WinCE
Keywords: Cc:
Game:

Description

scummvm-0.10.0svn-2007_05_02.zip

ERROR

Application Scummvm.Exe has performed an illegal operation and will be shut down. If the problem persist, contact the program vendor.

Program: SCUMMVM.EXE
Exception: 0xc0000005
Address: 00000000

File di Configurazione:

[scummvm]
action_mapping_version=5
stepY1=2
stepY2=10
stepY3=20
repeatTrigger=200
repeatX=4
repeatY=4
action_mapping=0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0111 0112 0114 0113 000d
stepX1=2
stepX2=10
stepX3=40
versioninfo=0.10.0svn

File scummvm_stderr.txt:

WARNING: Setting default action mappings.!

File: scummvm_stdout.txt

Creating configuration file: scummvm.ini
Using configuration file: scummvm.ini

Ticket imported from: #1714976. Ticket imported from: bugs/3185.

Change History (20)

comment:1 by SF/qwertypippo, 12 years ago

Owner: set to SF/knakos

comment:2 by SF/knakos, 12 years ago

Thanks for the bug report.
Have you tried editing scummvm.ini and putting the following line in the [scummvm] section:

landscape=1

and running scummvm again?

comment:3 by SF/knakos, 12 years ago

Summary: scummvm-0.10.0svn-2007_05_02.zip - ERRORWINCE: svn build startup crash

comment:4 by SF/knakos, 12 years ago

From private communication:

"I have performed the change from you recommend in the
scummvm.ini but nothing is changed.
In over after having launched scummvm.exe it modifies me
the scummvm.ini cancelling the line landscape=1"

OK, thanks for trying, will notify here when I have something ready.

comment:5 by SF/knakos, 12 years ago

Can you please recheck this using this executable?:

http://users.uoa.gr/~knakos/scummvm/binaries/scummvm_20070513.exe.bz2

This will probably crash as well, but I've improved the logging so I can understand what's going on.

Here's what I want you to do: Edit the scummvm.ini file and add a line in the [scummvm] secton with the following text:

debuglevel=1

then run, and if it still crashes paste in here the contents of scummvm_stdout/err files again.

Thanks.

comment:6 by SF/knakos, 12 years ago

Component: Engine: SCUMM--Unset--
Game: Monkey Island 3
Status: newpending

comment:7 by SF/qwertypippo, 12 years ago

Hi,knakos
I have done as you have told me,
I attach the list of errors

scummvm_stderr.txt
SDL: Bootstrapping GAPI device
SDL: Device is landscape
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: Checking for GAPI
SDL: Going for Ozone
SDL: Running on Ozone
SDL: Ozone unknown screen format
scummvm_stdout.txt
Using configuration file: scummvm.ini

comment:8 by SF/qwertypippo, 12 years ago

Status: pendingnew

comment:9 by SF/knakos, 12 years ago

"SDL: Ozone unknown screen format"

This is a severe error. I cannot do anything about this. But, I'm currently reworking some of the detection logic which may finally handle your device. Until then, I'm lowering the priority on this. When I have something ready, you'll be notified.

Thanks for the info.

comment:10 by SF/knakos, 12 years ago

Priority: normallow

comment:11 by SF/knakos, 12 years ago

It might help if you install GAPI on your device.

comment:12 by SF/qwertypippo, 12 years ago

I have installed gapi and following amount carried over the errors

scummvm_stderr.txt

SDL: Bootstrapping GAPI device
SDL: Device is landscape
SDL: GAPI_RealizePalette NOT IMPLEMENTED
SDL: Checking for GAPI
SDL: Found GAPI
SDL: Going for Ozone
SDL: Running on Ozone
SDL: Ozone unknown screen format
SDL: Running on Ozone driver at 320x214 (real 320, 240)
SDL: Running true Ozone with stylus hack

comment:13 by SF/knakos, 12 years ago

Thanks for your tests and quick replies.

This is a better situation, now that GAPI is installed. I hope I will be able to support your device with some changes I'm currently making to the SDL, so stay tuned.

comment:14 by sev-, 12 years ago

Would be nice to fix before release

comment:15 by SF/knakos, 12 years ago

Please test with this version: http://forums.scummvm.org/viewtopic.php?t=3916

In case it crashes, please reattach the usual debuglevel=1 output.

comment:16 by SF/qwertypippo, 12 years ago

thanks for the developed job, everything now works perfectly

comment:17 by SF/knakos, 12 years ago

Resolution: fixed
Status: newclosed

comment:18 by SF/knakos, 12 years ago

closing. thank you.

comment:19 by Strangerke, 6 years ago

Component: --Unset--Ports

comment:20 by digitall, 11 months ago

Component: PortsPort: WinCE
Note: See TracTickets for help on using tickets.