Opened 12 years ago

Closed 12 years ago

#3114 closed defect (fixed)

AGI: Entering text while screen is shaking

Reported by: eriktorbjorn Owned by: sev-
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: King's Quest 1

Description

Latest SVN snapshot

Entering text while the screen is shaking (e.g. after falling down the beanstalk for the umpteenth time in King's Quest 1) causes graphics glitches.

I'm guessing that the new text characters are drawn without compensating for the shake offsets.

Ticket imported from: #1678230. Ticket imported from: bugs/3114.

Attachments (3)

kq1.009 (1.1 KB) - added by eriktorbjorn 12 years ago.
Savegame before planting the beans
bug_1678230_fix.diff (728 bytes) - added by SF/mthreepwood 12 years ago.
Possible Fix
bug_1678230_fix_2.diff (774 bytes) - added by SF/mthreepwood 12 years ago.
Possible Fix (fixed)

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by sev-

Ummm... exact steps to reproduce? :)

Changed 12 years ago by eriktorbjorn

Attachment: kq1.009 added

Savegame before planting the beans

comment:2 Changed 12 years ago by eriktorbjorn

I've attached a King's Quest 1 savegame. Plant the beans, climb the beanstalk and (simplest of all) fall off. Keep typing rapidly as you land (causing the screen to shake), and you should be able to see it.
File Added: kq1.009

comment:3 Changed 12 years ago by wjp

The original KQ1 (in dosbox) ignores any keypresses while the screen is shaking.

Changed 12 years ago by SF/mthreepwood

Attachment: bug_1678230_fix.diff added

Possible Fix

comment:4 Changed 12 years ago by SF/mthreepwood

I'm attaching a possible patch that disables input while the screen is shaking. But, unfortunately I cannot test it.
File Added: bug_1678230_fix.diff

Changed 12 years ago by SF/mthreepwood

Attachment: bug_1678230_fix_2.diff added

Possible Fix (fixed)

comment:5 Changed 12 years ago by SF/mthreepwood

Attaching a second patch to avoid a possible regression.
File Added: bug_1678230_fix_2.diff

comment:6 Changed 12 years ago by eriktorbjorn

The patch works for me.

comment:7 Changed 12 years ago by sev-

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:8 Changed 12 years ago by sev-

Great, the patch was committed. The bug is fixed.

Note: See TracTickets for help on using tickets.