Opened 13 years ago

Last modified 7 years ago

#3110 new defect

ZAK: Time bug in airplane

Reported by: SF/hux- Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

There is no time in airplane to do the appropriate tasks.
As soon as the stewardess has handed over the peanuts you end up in the destination city.

Ticket imported from: #1676326. Ticket imported from: bugs/3110.

Attachments (1)

zak.s02 (6.9 KB ) - added by SF/hux- 13 years ago.
saved game from entering the airplane

Download all attachments as: .zip

Change History (25)

by SF/hux-, 13 years ago

Attachment: zak.s02 added

saved game from entering the airplane

comment:1 by sev-, 13 years ago

Summary: Time bug in airplaneZAK: Time bug in airplane

comment:2 by sev-, 13 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by SF/hux-, 13 years ago

Version: ScummVM 0.9.1
Bug details: Happens after a short while in the airplane. Sometimes you have a short time to walk in the plane, but never enough time to full fill the tasks.
Works great with Windows XP, but not so great with ScummVM 0.9.1.
Language: English
Installation: HTC P4350, Windows mobile.

comment:4 by fingolfin, 13 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newpending

comment:5 by fingolfin, 13 years ago

I can't reproduce this problem. I just went through the whole sequence in the airplane (toilet, microwaved egg, etc.), just fine. Like you using the V1 version (with the crappy old graphics).

hm, maybe you have "fast" or "very fast" mode activated by accident? (Ctrl-F / Ctrl-G) ?

comment:6 by SF/hux-, 13 years ago

I tryed out now running ScummVM on my computer (hadn't figured out it was possible) and it runs fine through the airplane sequence. This problem only seems to appear when i run ScummVM on my cell phone.
Perhaps my cell phone is too fast for an old game like this ;)

And yes its the very old version that runs on DOS/Windows.

comment:7 by SF/hux-, 13 years ago

Status: pendingnew

comment:8 by fingolfin, 13 years ago

Owner: changed from fingolfin to SF/knakos
Resolution: worksforme
Summary: ZAK: Time bug in airplaneWINCE/ZAK: Time bug in airplane

comment:9 by fingolfin, 13 years ago

Nah, your cell phone isn't too fast. Still, maybe for some odd reason the fast mode has been activated on the cell phone?

Knakos, can you reproduce this issue?

comment:10 by fingolfin, 13 years ago

Owner: SF/knakos removed
Summary: WINCE/ZAK: Time bug in airplaneZAK: Time bug in airplane

comment:11 by fingolfin, 13 years ago

Correction: I can reproduce the problem with your savegame, but not with other savegames of mine, nor when playing to that point right form the start of the game.

So I am tempted to close this as a case a of "broken savegame". But maybe you can reproduce this from other savegames or even when playing from the start of the game straight to this point, too?

comment:12 by bluegr, 13 years ago

This should be renamed to:
"WINCE: Timing bug in the airplane in ZAK"
cause it seems to be more like a WINCE issue rather than an issue with ZAK itself

comment:13 by fingolfin, 13 years ago

No. As I stated, I can reproduce the problem (on Mac OS X). So it's not WINCE specific.

comment:14 by SF/hux-, 13 years ago

I have now tryed to reinstall the game and started a fresh new game and still have this bug.
I am starting to wonder if its a time bug, since I figured out it seems to happen when I start doing stuff in the airplane. If I just sit and do nothing I wont be thrown out of the airplane either.

comment:15 by fingolfin, 13 years ago

Ah. Can you then perhaps give a precise step-by-step guide with which you can often/always reproduce the issue, starting from the airport? Timing might be important, too.

comment:16 by SF/hux-, 13 years ago

At first when I noticed this issue it used to happen after a short while in the airplane. I could open some of the lockers and the stewardes would come and tell me to sit down, but now when I step in the airplane for the first time and get handed the peanuts from the stewardes I get thrown out if I click anywhere on the game-screen with my pen. It does that aswell if I use some of the buttons on my cell phone. If I decide to just sit I wont be thrown out for perhaps 10 minutes.
If I choose a flight after that I am often able to walk abit, eg. I've managed to reach the toilets once and then been thrown out from the plane.
I am not sure if it has anything to do with the destination I choose at the airport. Would you like me to time the throw-outs on some of the destinations?

comment:17 by sev-, 12 years ago

What is the status of this item?

comment:18 by sev-, 11 years ago

Raising priority. This bug is nice to get fixed before the release.

comment:19 by sev-, 11 years ago

Priority: normalhigh

comment:20 by sev-, 10 years ago

Owner: set to fingolfin

comment:21 by fingolfin, 8 years ago

Owner: fingolfin removed

comment:22 by sev-, 8 years ago

Priority: highnormal

comment:23 by sev-, 8 years ago

Lowering priority/

comment:24 by SF/spellbreaker, 7 years ago

Just wanted to say that this is still an issue. Tested on Android ( different versions up to 2.3.4). Only happens with FM Towns version, other Versions work well for me.
(Latest Version available on Android Market )...

Note: See TracTickets for help on using tickets.