Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3106 closed defect (fixed)

FOTAQ: problem with nested installation folders

Reported by: SF/h3xx Owned by: fingolfin
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

My problem is that whenever I start the uncompressed full version of FOTAQ (from the gui or by `/usr/bin/scummvm queen`) the compressed demo starts instead.

I set up my scumm "repository" at /usr/share/games/scumm/.

I have the uncompressed version of FOTAQ (target: "queen") installed thus:
/usr/share/games/scumm/queen/queen.1
/usr/share/games/scumm/queen/queen.tbl

I also have the compressed demo version (target: "queen-demo") installed thus:
/usr/share/games/scumm/queen/_demo/queen.1c
/usr/share/games/scumm/queen/_demo/queen.tbl

When I add the full-version game folder through the gui, it detects it just fine (I forget at the moment exactly what the description tag looks like, but it does NOT say 'Demo'). The same hold true for adding the _demo/ folder; it tells me it detects the demo version.

I tried renaming the _demo folder to .demo then updating ~/.scummvmrc and that worked just fine, but I can't browse to it in the gui. From what I can tell it's searching the install dir recursively for an operable queen.1c (which it finds at _demo/queen.1c) THEN, failing that, searching recursively for queen.1.

Renaming queen.1 to queen.1c doesn't work, but I wouldn't expect it to.

I'm running Scummvm recently (two days ago) compiled from svn revision 25919, give or take.

Ticket imported from: #1672098. Ticket imported from: bugs/3106.

Change History (5)

comment:1 by fingolfin, 13 years ago

Owner: set to sev-
Summary: problem with nested installation foldersFOTAQ: problem with nested installation folders

comment:2 by fingolfin, 13 years ago

Haven't actually tried it, but this might be caused by the fact that we invoke
Common::File::addDefaultDirectoryRecursive(ConfMan.get("path"));
in base/main.cpp. I am not quite sure why we add "path" *recursively here -- seems odd to me. Eugene, any particular reasons for doing it that way?

comment:3 by fingolfin, 13 years ago

Owner: changed from sev- to fingolfin
Resolution: fixed
Status: newclosed

comment:4 by fingolfin, 13 years ago

I have replaced the addDefaultDirectoryRecursive call in question by addDefaultDirectory, which should solve your problem. Still, I would strongly recommend against nesting games like this. If you want to group all your FOTAQ/queen version, do so by using parallel dirs, e.g.
/usr/share/games/scumm/queen/full
/usr/share/games/scumm/queen/demo
or so (or use "cd", "floppy", "demo"... whichever you like).

As for the change I made:

* We already used the non-recursive version when no path was specified and hence we defaulted back to "." -- so this change makes the code bahave more consistent over all

* There seems to be no justification for adding the path recusively. If certain games require this, then their respective game engine(s) should invoke addDefaultDirectoryRecursive in a suitable location.

comment:5 by sev-, 13 years ago

Yes, several HE games have their datafiles nested in subdirectories. Now they are broken.

Note: See TracTickets for help on using tickets.