Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#3102 closed defect (fixed)

SWORD1: game won't load (ogg compression) (regression)

Reported by: spookypeanut Owned by: fingolfin
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

As soon as the intro cutscene is finished (or a savegame is loaded), scummvm errors out, saying:

File::open: This file object already is opened (SPEECH1.CLV), won't open 'SPEECH1.CL3'!

The game is ogg compressed, so speech1.clv exists but speech1.cl3 does not (i double checked :-). So it looks like something to do with recent ogg work. I don't have the discs here, but will try it with uncompressed version later on.

Running r25895, compiled on ubuntu.

Ticket imported from: #1670081. Ticket imported from: bugs/3102.

Change History (6)

comment:1 by bluegr, 13 years ago

Perhaps commit #25837 caused this? Although I can't see anything wrong with it....

comment:2 by fingolfin, 13 years ago

If it's OGG/MP3/Flac related, it's probably caused by my recent code overhaul. I'll take a look when time permits.

comment:3 by fingolfin, 13 years ago

Owner: set to fingolfin
Summary: SWORD1 regression: game won't load (ogg compression)SWORD1: game won't load (ogg compression) (regression)

comment:4 by spookypeanut, 13 years ago

I checked last night (27 Feb), using the daily build on windows, and yes it is ogg related: the uncompressed files work fine.

comment:5 by fingolfin, 13 years ago

Fixed in SVN. Pretty stupid copy&paste error :-). Thanks for pointing this out.

comment:6 by fingolfin, 13 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.