Opened 18 years ago

Closed 18 years ago

Last modified 12 months ago

#31 closed defect (fixed)

Indy4 crashing at the submarine

Reported by: SF/pigeon Owned by: SF/strigeus
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

After Indy getting on the submarine and showing the
submarine movement map, scummvm crashed with seg fault.

Program received signal SIGSEGV, Segmentation fault.
0x806e050 in READ_BE_UINT32 (ptr=0x4) at scummsys.h:135
135 return
(b[0]<<24)+(b[1]<<16)+(b[2]<<8)+(b[3]);

(gdb) bt
#0 0x806e050 in READ_BE_UINT32 (ptr=0x4) at
scummsys.h:135
#1 0x80574e6 in findResource (tag=1145589065,
searchin=0x4 <Address 0x4 out of bounds>, index=0)
at resource.cpp:631
#2 0x80610f5 in Scumm::drawVerbBitmap (this=0x807a900,
vrb=50, x=64, y=152)
at verbs.cpp:188
#3 0x8060e60 in Scumm::drawVerb (this=0x807a900,
vrb=50, mode=0)
at verbs.cpp:115
#4 0x8066c44 in Scumm::o5_verbOps (this=0x807a900) at
script_v1.cpp:1791
#5 0x8059ad5 in Scumm::executeScript (this=0x807a900)
at script.cpp:260
#6 0x805974a in Scumm::runScriptNested
(this=0x807a900, script=5)
at script.cpp:183
#7 0x8059395 in Scumm::runScript (this=0x807a900,
script=201, a=0, b=0,
lvarptr=0xbffff6b4) at script.cpp:70
#8 0x80663eb in Scumm::o5_startScript (this=0x807a900)
at script_v1.cpp:1591
#9 0x8059ad5 in Scumm::executeScript (this=0x807a900)
at script.cpp:260
#10 0x805974a in Scumm::runScriptNested
(this=0x807a900, script=1)
at script.cpp:183
#11 0x805a808 in Scumm::runEntryScript (this=0x807a900)
at script.cpp:541
#12 0x805cbe7 in Scumm::startScene (this=0x807a900,
room=66, a=0x0, objectNr=0)
at scummvm.cpp:556
#13 0x8064b6a in Scumm::o5_loadRoom (this=0x807a900) at
script_v1.cpp:1059
#14 0x8059ad5 in Scumm::executeScript (this=0x807a900)
at script.cpp:260
#15 0x805a58d in Scumm::runAllScripts (this=0x807a900)
at script.cpp:506
#16 0x805c319 in Scumm::scummLoop (this=0x807a900,
delta=6) at scummvm.cpp:294
#17 0x8062893 in main (argc=2, argv=0xbffff8f4) at
sdl.cpp:647

Ticket imported from: #480281. Ticket imported from: bugs/31.

Attachments (1)

atlantis.s08 (51.5 KB ) - added by SF/pigeon 18 years ago.
Save game before the seg fault

Download all attachments as: .zip

Change History (6)

by SF/pigeon, 18 years ago

Attachment: atlantis.s08 added

Save game before the seg fault

comment:1 by SF/jackburton, 18 years ago

You are referring to the "team" path, right?
BTW, indy4 is finishable with "wits" and "action" path .

comment:2 by SF/strigeus, 18 years ago

I don't think I have the same version of indy4 as you, so
the savegame won't work for me.

I'm looking into the bug however.

comment:3 by SF/strigeus, 18 years ago

Owner: set to SF/strigeus
Resolution: fixed
Status: newclosed

comment:4 by SF/strigeus, 18 years ago

Bug was caused by a typo in verbs.cpp
It's fixed

comment:5 by digitall, 12 months ago

Component: Engine: SCUMM
Game: Indiana Jones 4
Note: See TracTickets for help on using tickets.