Opened 13 years ago

Closed 13 years ago

#3090 closed defect (fixed)

GOB: wrong detection

Reported by: SF/cybot_tm Owned by: sev-
Priority: low Component: Engine: Gob
Keywords: Cc:
Game: Gobliiins

Description

scummvm detects 'Bargon Attacks' as Gobliiins (unknown/DOS)

using scummvm 2007-02-25 win32

Ticket imported from: #1667806. Ticket imported from: bugs/3090.

Change History (13)

comment:1 by SF/cybot_tm, 13 years ago

-d2 debug output:

Looking for gob
Trying to start game 'Gob engine game'
Your game version appears to be unknown. Please, report the following
data to the ScummVM team along with name of the game you tried to add
and its version/language/etc.:
intro.stk: 'a7b51f4454e27106c8d04c9404ddb981', 269944
intro.stk.: 'a7b51f4454e27106c8d04c9404ddb981', 269944

WARNING: But it looks like unknown variant of gob1!
File musmac1.mid not found
File musmac1.mid. not found
Your game version appears to be unknown. Please, report the following
data to the ScummVM team along with name of the game you tried to add
and its version/language/etc.:
intro.stk: 'a7b51f4454e27106c8d04c9404ddb981', 269944
intro.stk.: 'a7b51f4454e27106c8d04c9404ddb981', 269944

File gob.lic not found
File gobnew.lic not found
WARNING: But it looks like unknown variant of gob1!
Running Gobliiins (unknown/DOS)
WARNING: GOB2 Stub! _word_2E8E2, _word_2E51F, _off_2E51B, _off_2E517!
WARNING: GOB2 Stub! _byte_2FC82, _byte_2FC83, _word_2FC80!
WARNING: GOB2 Stub! _byte_2FC9B, _dword_2F2B6!
WARNING: GOB2 Stub! _word_2F9C0, _word_2F9BE, _word_2F9BC, _word_2F9BA, _dword_2
F9B6, _dword_2F9B2!
WARNING: STUB: Video::initDriver!
File intro.inf not found
File gob.lic not found
File intro.ext not found
WARNING: o1_palLoad: cmd == 49 is not supported!
WARNING: unimplemented opcodeDraw: 64!

comment:2 by DrMcCoy, 13 years ago

Well, the version isn't known, so the file-based fallback kicks in.
To correctly add it, I'd like to know the game's language.

comment:3 by DrMcCoy, 13 years ago

Owner: set to DrMcCoy

comment:4 by SF/cybot_tm, 13 years ago

spanish

comment:5 by fingolfin, 13 years ago

Fan-translated, as with your other reports, or is this a regular "official" version?

comment:6 by fingolfin, 13 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:7 by fingolfin, 13 years ago

Status: newpending

comment:8 by SF/cybot_tm, 13 years ago

Status: pendingnew

comment:9 by SF/cybot_tm, 13 years ago

what is the problem if this fan translated? it is not important if this is fan translated or not, or what game it is at all - the problem is that scummvm thinks this is Gobliiins - what is not right

i do not know if you take care of this - if not just close the report of course

i did not found any document about your policy with md5s - if yu could point me to some document i will try to not 'spam' your bug tracker ... ;-)

comment:10 by fingolfin, 13 years ago

We do not collect MD5s of fan translations at all, which is why I asked. Hence this should *not* be added to the list of MD5s, DrMcCoy.

However, we could/should still try to enhance the fallback detector to deal with this more gracefully, if that's possible w/o causing too much pain.

comment:11 by fingolfin, 13 years ago

Priority: normallow

comment:12 by sev-, 13 years ago

Owner: changed from DrMcCoy to sev-
Resolution: fixed
Status: newclosed

comment:13 by sev-, 13 years ago

I enchanced fallback detector to properly recognize bargon. Then bug should be fixed.

Note: See TracTickets for help on using tickets.