Opened 17 years ago

Closed 17 years ago

Last modified 10 years ago

#307 closed defect (fixed)

simon1dos: linux path case sensitive bug

Reported by: SF/meeuw Owned by: SF/ender
Priority: low Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

$ ./scummvm -p ~/bin/Simon simon1dos
Unable to open configuration file:
/home/meeuw/.scummvmrc.

Detected game 'Simon the Sorcerer 1 for DOS', version
99.99.99
WARNING: loading /home/meeuw/bin/simongamepc.
!
Error: Error loading gamepc file 'GAMEPC' (or one of the
files it depends on)!

when i renamed the "~bin/Simon" directory to
"~bin/simon" it worked... I suppose this wouldn't be too
difficult to fix...

btw I'm using CVS 20020615

Ticket imported from: #569333. Ticket imported from: bugs/307.

Change History (12)

comment:1 by SF/meeuw, 17 years ago

Priority: normallow

comment:2 by SF/ender, 17 years ago

Component: --Unset--
Owner: set to SF/ender
Resolution: fixed

comment:3 by SF/ender, 17 years ago

This should be fixed in the current CVS. Can you try it (with
the uppercase path) and let me know? Cheers.

comment:4 by SF/meeuw, 17 years ago

Component: --Unset--Engine: AGOS
Game: Simon the Sorcerer 1

comment:5 by SF/meeuw, 17 years ago

$ ./scummvm -p ~meeuw/bin/Simon simon1dos
Unable to open configuration file: /home/meeuw/.scummvmrc.

Detected game 'Simon the Sorcerer 1 for DOS', version
99.99.99
Error: Error loading gamepc file 'GAMEPC' (or one of the files
it depends on)!

and I have a gamepc (in lower-case).
I don't think -thats- a bug, it is a dos script after all...

I've found a nice kornshell script on:
http://www.mort.level5.net/johnr/shell/lower2upper.txt

#!/bin/ksh
#
# lower2upper.sh
#
# Shell script for changing all lowercase filenames in a
directory
# to uppercase filenames.
#
# John Roebuck - 01/03/2002

for oldfile in *
do

newfile=`echo $oldfile| tr 'a-z' 'A-Z'`

if [ $newfile != $oldfile ]
then
mv $oldfile $newfile
fi
done

Now my ol' Simon works! :-) whiii

I don't think you'll need to fix this... If the game scripts requests
files in uppercase you'll need to feed it with it...

Great work!

comment:6 by (none), 17 years ago

Logged In: NO

Actually, thats not the problem. ScummVM automatically
trys lower AND upper case. The problem is that your -p
command is missing a trailing slash!

./scummvm -p ~/bin/Simon/ simon1dos is what you should
have used

comment:7 by SF/meeuw, 17 years ago

Hmm... you are right. It works fine!
Silly me... Maybe the error message should contain the full
pathname to the file?

comment:8 by SF/ender, 17 years ago

Actually, I'll add checking for trailing slashes in the future :)

Closing bug as definatly fixed.

comment:9 by SF/ender, 17 years ago

Status: newclosed

comment:10 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Owner: SF/ender removed
Status: closednew

comment:11 by Kirben, 17 years ago

Component: Engine: AGOS
Game: Simon the Sorcerer 1
Status: newclosed

comment:12 by Kirben, 10 years ago

Owner: set to SF/ender
Note: See TracTickets for help on using tickets.