Opened 13 years ago

Closed 13 years ago

Last modified 10 years ago

#3069 closed defect (fixed)

MANIACNES: Graphics glitch on intro screen

Reported by: fingolfin Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

The very first screen MM NES shows you, i.e. the intro screen with the big tree and the meteor, contains graphic glitches; in particular, parts of the tree are drawn incorrectly. The attached screenshot exemplifies this.

Reproduced with latest SVN as of today (rev 25604).
Confirmed to not happen in the original.

Ticket imported from: #1660550. Ticket imported from: bugs/3069.

Attachments (1)

mm-nes-intro-glitch.png (6.3 KB ) - added by fingolfin 13 years ago.

Download all attachments as: .zip

Change History (8)

by fingolfin, 13 years ago

Attachment: mm-nes-intro-glitch.png added

comment:1 by fingolfin, 13 years ago

File Added: mm-nes-intro-glitch.png

comment:2 by fingolfin, 13 years ago

Note: This is for the US version of MM NES.

comment:3 by SF/quietust, 13 years ago

I'm not seeing any difference between the attached screenshot and Nestopia, other than possible artifacts introduced by the graphics filter you're using (looks like supereagle or advmame2x).

Are there still glitches present when using the 1X/2X/3X filters?

comment:4 by fingolfin, 13 years ago

Yes. The glitch (i.e. the off-color squares around the tree) are present independant of the scalar (I fail to see how a scaler could possibly introduce off-colors squares in the first place, anyway -- unless it's a very very buggy scaler, of course :).

comment:5 by fingolfin, 13 years ago

The problem was caused by "bad" palette data. Fixed as suggested by quietust on iRC.

comment:6 by fingolfin, 13 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:7 by sev-, 10 years ago

In fact this fix was wrong, and the described "glitches" are intended. See bug #2846887.

Reverting

Note: See TracTickets for help on using tickets.