Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3060 closed defect (invalid)

GOB2: Game freeze

Reported by: SF/arcepi Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliins 2

Description

Gobliins 2 (spanish DOS version) makes ScummVM freeze. It seems this version isn't recognized:

Trying to start game 'Gob engine game'
MD5s of your game version are unknown. Please, report following data to
ScummVM team along with your game name and version:
intro.stk: "5f53c56e3aa2f1e76c2e4f0caa15887f", 829232
intro.stk.: "5f53c56e3aa2f1e76c2e4f0caa15887f", 829232
WARNING: But it looks like unknown variant of gob2!

I have attached a saved game that reproduces the crash when you try to exit using the stairs.

I'm using the latest SVN version:

C:\ScummVM>scummvm.exe -v
Using configuration file: C:\Documents and Settings\Leticia\Datos de programa\Sc
ummVM\scummvm.ini
ScummVM 0.10.0svn (Feb 13 2007 00:03:03)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Ticket imported from: #1659884. Ticket imported from: bugs/3060.

Attachments (2)

gob2 savegame.zip (26.7 KB) - added by SF/arcepi 12 years ago.
Savegame that makes ScummVM freeze
log.zip (13.7 KB) - added by SF/arcepi 12 years ago.
Debug output

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by SF/arcepi

Attachment: gob2 savegame.zip added

Savegame that makes ScummVM freeze

comment:1 Changed 12 years ago by bluegr

That's hardly a "Game freeze" as you claim - it's merely an unknown version

comment:2 Changed 12 years ago by SF/arcepi

thebluegr: Have you tested the saved game and it didn't freeze using a recognized version?

comment:3 Changed 12 years ago by DrMcCoy

Hmm, I can't reproduce it here, could you run ScummVM with "-d1 --debugflags=DrawOpcodes,FuncOpcodes,GoblinOpcodes", play till the freeze and attach the output here?

comment:4 Changed 12 years ago by DrMcCoy

Component: Engine: Gob
Game: Gobliins 2
Owner: set to DrMcCoy

Changed 12 years ago by SF/arcepi

Attachment: log.zip added

Debug output

comment:5 Changed 12 years ago by SF/arcepi

I've attached the debug output. It seems to enter in some kind of infinite loop repeating:

opcodeFunc 0.0 [0x0.0x0] (o1_callSub)
opcodeFunc 3.15 [0x3.0xf] (o2_checkData)

until I close scummvm.
File Added: log.zip

comment:6 Changed 12 years ago by DrMcCoy

Could it be that you didn't (correctly?) copy disk3.stk from the 3rd floppy into your game directory?
Removing that file produces exactly that effect here.

comment:7 Changed 12 years ago by SF/arcepi

That was the problem. I had no disk3.stk because I just copied the contents of floppys but didn't run install.

Sorry for wasting your time. Shouldn't ScummVM tell the user that a file is missing?

comment:8 Changed 12 years ago by DrMcCoy

> Shouldn't ScummVM tell the user that a file is missing?

Hmm, yes, the current SVN version / next daily build warns now when checkData() can't find the file...

comment:9 Changed 12 years ago by DrMcCoy

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.