Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#3056 closed defect (fixed)

AGI: SQ1 (2.2 DOS ENG) bizzare exploding roger

Reported by: SF/glo_kidd Owned by: bluegr
Priority: low Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 1

Description

Hi all, i have been testing Space Quest: The sarien Encounter (2.2 1987/05/07 5.25"/3.5"/DOS/English)with the Win32 SVN build of (feb/13/2007 00:03:03)
On the planet korona, after talking to the big head about orat, when trying to return down the path roger *sometimes* explodes.
I have been able to re-create this a few times. From the attached savegame walk south down the path, then wait for the spider droid and return north back up the path. return south now and try to actually leave the path. This is where roger usually explodes despite that the driod is usually far from him.
Sorry for the huge re-creation instructions but this seemes to happen pretty consistantly when following these steps.

The specific version that i am using is from the 199x SQ collection release

I hope this helps, let me know if you need any more testing. Im always willing to help :)

Ticket imported from: #1658514. Ticket imported from: bugs/3056.

Attachments (2)

sq1.005 (1.2 KB ) - added by SF/glo_kidd 13 years ago.
Exploding roger
SQSG.1 (2.7 KB ) - added by SF/glo_kidd 13 years ago.
explodebug save (original interpreter)

Download all attachments as: .zip

Change History (13)

by SF/glo_kidd, 13 years ago

Attachment: sq1.005 added

Exploding roger

comment:1 by SF/dsx, 13 years ago

Thanks for the report.

Is this reproducable with the original Sierra interpreter (say, using DOSBox)?

comment:2 by SF/dsx, 13 years ago

Summary: SQ1 (2.2 DOS ENG) bizzare exploding rogerAGI: SQ1 (2.2 DOS ENG) bizzare exploding roger

comment:3 by SF/glo_kidd, 13 years ago

I Just tested with the original interpreter and the bug is present there too. *oops* sorry about that,i guess it would then be advisable to not avoid the spider droid in that way (unless you REALLY want to watch roger spontaneously combust :D )

sorry the report wasnt that hepfull :(

comment:4 by SF/dsx, 13 years ago

No, don't apologise. I'm sure other people will come across this, and it's perhaps worth investigating and figuring out a work-around. Can you attach a savegame for the original interpreter?

comment:5 by SF/dsx, 13 years ago

(nominally marking this as "won't fix" for now).

comment:6 by SF/dsx, 13 years ago

Priority: normallow
Resolution: wontfix
Status: newpending

by SF/glo_kidd, 13 years ago

Attachment: SQSG.1 added

explodebug save (original interpreter)

comment:7 by SF/glo_kidd, 13 years ago

okay, i uploaded the savegame. the savegames original name is "explodebug".
Im glad this has been able to help, let me know if there is anything else i can do
File Added: SQSG.1

comment:8 by SF/glo_kidd, 13 years ago

Status: pendingnew

comment:9 by sev-, 13 years ago

Component: Engine: AGI
Game: Space Quest 1

comment:10 by bluegr, 12 years ago

Added a workaround for this script bug, which properly initializes a flag in the relevant script for this scene, which was the cause for this erroneous actor behavior. The bug should be fixed in the current SVN

Closing

comment:11 by bluegr, 12 years ago

Owner: set to bluegr
Resolution: wontfixfixed
Status: newclosed
Note: See TracTickets for help on using tickets.