Opened 12 years ago

Closed 12 years ago

Last modified 7 months ago

#3048 closed defect

AGI: Some MD5 checksums

Reported by: bluegr Owned by: sev-
Priority: normal Component: Engine: AGI
Keywords: detection Cc:
Game:

Description

These versions used to work with the AGI module before the changes to the game detector. I've added the number to the right of the MD5 checksum too, not sure what it means

Donald Duck's Playground
"550971d196f65190a5c760d2479406ef", 132

Space Quest II
"ad7ce8f800581ecc536f3e8021d7a74d", 423

Gold Rush
"3ae052117feb483f01a9017025fbb366", 2399

Manhunter 1
"0c7b86f05fe02c2e26cff1b07450b82a", 2123

Ticket imported from: #1654500. Ticket imported from: bugs/3048.

Change History (13)

comment:1 Changed 12 years ago by sev-

May you elaborate a bit what are these versions? I.e. which platform, which media and which game version.

comment:2 Changed 12 years ago by bluegr

They're all english PC floppy versions, not sure how to find the game version

comment:3 Changed 12 years ago by sev-

run game in dosbox and press Alt+D

comment:4 Changed 12 years ago by bluegr

Donald Duck's Playground

Version: 1.0C
AGI version: 2.272

Space Quest II

Version: 2.0A
AGI version: 2.912

Gold Rush

Version: 2.01 (Dec 22, 1988)
AGI version: 3.002.149

Manhunter 1

Version: 1.22 (Aug 31, 1988)
AGI version: 3.002.102

comment:5 Changed 12 years ago by sev-

Owner: set to sev-
Status: newclosed

comment:6 Changed 12 years ago by sev-

I added all but sq2 which seems to be completely unknown. Perhaps cracked version or bad copy from the floppy.

comment:7 Changed 12 years ago by bluegr

You were right about SQ2, copied it again and it works now. Strange

comment:8 Changed 12 years ago by bluegr

OK I'm a bit confused here. I see you've added SQ2's MD5 twice. Donald Duck's Playground has been added correctly, but I see you've also added the MD5s of Space Quest II and Manhunter 1 twice, and you haven't added Gold Rush's MD5. Could you please recheck your commit?

I'm opening this bug report again until the commit has been confirmed

comment:9 Changed 12 years ago by bluegr

Status: closednew

comment:10 Changed 12 years ago by bluegr

Update: when I tried SQ2 the second time, I used an older version of ScummVM (before the changes to the detector - I recompiled the wrong project). Sorry for the confusion

comment:11 Changed 12 years ago by bluegr

Follow-up: it seems my Gold Rush version is messed up indeed, it does work under the older ScummVM build that I've got, but I get a CRC error when it starts. The rest of the games are recognised fine under the old build too, so it seems my copy of Gold rush is faulty. I'll have to find the original media in my attic at some point (if I remember where they're stored, that is :( )
Thanks for your time, closing this as it's resolved :)

comment:12 Changed 12 years ago by bluegr

Status: newclosed

comment:13 Changed 7 months ago by digitall

Component: Engine: AGI
Note: See TracTickets for help on using tickets.