Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#3042 closed defect (duplicate)

SPYFOX 1: Graphics overdrawn in the "Go Fish!" game

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Spy Fox 1

Description

ScummVM 0.10.0svn (Feb 3 2007 16:37:33)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

In the "Go Fish!" game when loading a save game directly into a game
(or AFTER starting one already) the deck of cards are wrongly overwritten
by a dropped set of cards when SpyFox looses one or more cards (see
screengrab).

The "same" happens in the "fun" game in SpyFox's SpyWatch, one can play the
game but the little U-Boat erases everything around it to black, making it
VERY difficult to play (i think this is related)

Also, this may be related to bug #1441950 (The Lift glitch after reloading
a saved game)

SpyFox 1: Dry Cereal
English CD

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1651329. Ticket imported from: bugs/3042.

Attachments (3)

SpyFox.jpg (69.5 KB) - added by SF/*anonymous 12 years ago.
Cards overdrawn
spyfox.s02 (14.9 KB) - added by SF/*anonymous 12 years ago.
Save Game, right at the beginning of a Go Fish! game
SpyFox1.jpg (32.8 KB) - added by SF/*anonymous 12 years ago.
Broken "Happy Fun Sub"

Download all attachments as: .zip

Change History (16)

Changed 12 years ago by SF/*anonymous

Attachment: SpyFox.jpg added

Cards overdrawn

Changed 12 years ago by SF/*anonymous

Attachment: spyfox.s02 added

Save Game, right at the beginning of a Go Fish! game

comment:1 Changed 12 years ago by (none)

File Added: spyfox.s02

Changed 12 years ago by SF/*anonymous

Attachment: SpyFox1.jpg added

Broken "Happy Fun Sub"

comment:2 Changed 12 years ago by (none)

File Added: SpyFox1.jpg

comment:3 Changed 12 years ago by Kirben

The original game wouldn't allow loading or saving at these particular locations, I expect that is why the issues occur.

If the 'l' and 's' keys don't work at a location under ScummVM, that original game didn't allow loading or saving at that location.

comment:4 Changed 12 years ago by Kirben

Summary: HE SPYFOX 1: Graphics overdrawn in the "Go Fish!" gameSPYFOX 1: Graphics overdrawn in the "Go Fish!" game

comment:5 Changed 12 years ago by Kirben

The original game wouldn't allow loading or saving at these particular locations, I expect that is why the issues occur.

If the 'l' and 's' keys don't work at a location under ScummVM, that original game didn't allow loading or saving at that location.

comment:6 Changed 12 years ago by sev-

Can we produce some king of user-visible warning in this case?

I.e. something like "Orignial game did not allow to save at this point. You may get glitches. Proceed? (y/N)"

comment:7 Changed 12 years ago by fingolfin

That depends on how the original game handled the keys / determined whether to enable load/save. If this was controlled by a script variable, for example, it should be pretty easy to do.

BTW, many other SCUMM games can get into troubles when saving in the wrong spot / at the wrong time, so we might want to extend this warning to some of them.

comment:8 Changed 12 years ago by sev-

So, should we just reject this bugreport?

comment:9 Changed 12 years ago by sev-

Status: newpending

comment:10 Changed 12 years ago by SF/sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:11 Changed 12 years ago by SF/sf-robot

Status: pendingclosed

comment:12 Changed 10 years ago by Kirben

Owner: set to Kirben
Resolution: duplicate

comment:13 Changed 10 years ago by Kirben

Closing as duplicate of bug #1726909.

Note: See TracTickets for help on using tickets.