Opened 13 years ago

Closed 12 years ago

Last modified 12 months ago

#3031 closed defect (fixed)

AGI : SQ2 / 2.0F / IBM / priority line

Reported by: SF/darkfiber Owned by: bluegr
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 2

Description

AGI : SQ2 : 2.0F / IBM 3.5" : Priority line off by 1

priority bug, roger can 'wak through' the crashed ship a pixel too far.

Looks like an off-by-1 bug when comparing priority lines

Ticket imported from: #1648396. Ticket imported from: bugs/3031.

Change History (6)

comment:1 by eriktorbjorn, 13 years ago

I see I accidentally filed a duplicate of this as bug #1677840. I'll just paste the maybe-relevant part of it here, so we'll have all information in one place:

"This glitch does not happen with DOSbox or NAGI.

It could be a problem with checkPriority(). If I change that to always return 1, I can walk right through the wreckage. The corresponding function in NAGI appears to be obj_chk_control().

NAGI's objs_step_update() triggers when Y reaches 144 to move you back to 143. Our updatePosition() triggers when Y reaches 145 and moves you back to 144. Assuming they handle coordinates the same way, something's different."

comment:2 by bluegr, 13 years ago

Submitted a patch for this issue (patch #1705791)

comment:3 by bluegr, 12 years ago

Status: newclosed

comment:4 by bluegr, 12 years ago

Submitted patch, issue should be fixed now with latest SVN

Closing this

comment:5 by bluegr, 12 years ago

Owner: changed from SF/darkfiber to bluegr
Resolution: fixed

comment:6 by digitall, 12 months ago

Component: Engine: AGI
Game: Space Quest 2
Note: See TracTickets for help on using tickets.