Opened 13 years ago

Closed 13 years ago

Last modified 12 months ago

#3022 closed defect (fixed)

DC: SVN does not compile

Reported by: SF/erwan2004 Owned by: zeldin
Priority: normal Component: Port: Dreamcast
Keywords: Cc:
Game:

Description

Hello

To change, version SVN of port DREAMCAST does not compile.
[Babel Fish]

Host Suse 10.2 64bit
Toolchain SH : gcc-4.0.1_binutils-2.16_newlib-1.15.0

error:
sh-elf-g++ -ml -m4-single-only -Wp,-MMD,"./.deps/selector.d",-MQ,"selector.o",-MP -O3 -Wno-multichar -funroll-loops -fschedule-insns2 -fomit-frame-pointer -fdelete-null-pointer-checks -fno-exceptions -D__DC__ -DNONSTANDARD_PORT -DUSE_MAD -DDYNAMIC_MODULES -DDISABLE_SCALERS -I./ -I../../.. -I../../../common -I/home/erwan/Dreamcast/ronin-src/include/ -I../../../engines -c selector.cpp -o selector.o
selector.cpp:150: erreur: ‘DetectedGameList’ has not been declared
selector.cpp: In function ‘void detectGames(FSList&, int&)’:
selector.cpp:155: erreur: request for member ‘push_back’ in ‘candidates’, which is of non-class type ‘int’
selector.cpp: In function ‘int findGames(Game*, int)’:
selector.cpp:228: erreur: ‘DetectedGameList’ was not declared in this scope
selector.cpp:228: erreur: expected `;' before ‘candidates’
selector.cpp:229: erreur: ‘candidates’ was not declared in this scope
selector.cpp:231: erreur: ‘DetectedGameList’ is not a class or namespace
selector.cpp:231: erreur: variable ‘const_iterator ge’ has initializer but incomplete type
make: *** [selector.o] Erreur 1
mkdir -p ./.deps
sh-elf-g++ -ml -m4-single-only -Wp,-MMD,"./.deps/selector.d",-MQ,"selector.o",-MP -O3 -Wno-multichar -funroll-loops -fschedule-insns2 -fomit-frame-pointer -fdelete-null-pointer-checks -fno-exceptions -D__DC__ -DNONSTANDARD_PORT -DUSE_MAD -DDYNAMIC_MODULES -DDISABLE_SCALERS -I./ -I../../.. -I../../../common -I/home/erwan/Dreamcast/ronin-src/include/ -I../../../engines -c selector.cpp -o selector.o
selector.cpp:150: erreur: ‘DetectedGameList’ has not been declared
selector.cpp: In function ‘void detectGames(FSList&, int&)’:
selector.cpp:155: erreur: request for member ‘push_back’ in ‘candidates’, which is of non-class type ‘int’
selector.cpp: In function ‘int findGames(Game*, int)’:
selector.cpp:228: erreur: ‘DetectedGameList’ was not declared in this scope
selector.cpp:228: erreur: expected `;' before ‘candidates’
selector.cpp:229: erreur: ‘candidates’ was not declared in this scope
selector.cpp:231: erreur: ‘DetectedGameList’ is not a class or namespace
selector.cpp:231: erreur: variable ‘const_iterator ge’ has initializer but incomplete type
make: *** [selector.o] Erreur 1

Ticket imported from: #1645857. Ticket imported from: bugs/3022.

Change History (4)

comment:1 by fingolfin, 13 years ago

Owner: set to zeldin

comment:2 by zeldin, 13 years ago

Resolution: fixed
Status: newclosed

comment:3 by zeldin, 13 years ago

Caused by change from DetectedGameList to GameList in game detector API.
Fix committed.

comment:4 by digitall, 12 months ago

Component: Port: Dreamcast
Note: See TracTickets for help on using tickets.