Opened 13 years ago

Closed 13 years ago

#3001 closed defect (fixed)

GOB2: No Ending

Reported by: SF/exofreeze Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliins 2

Description

- ScummVM SVN: January 11, 2007, 11:01 pm, Win32
- Crahes during load for ending
- Gobliins 2 CD Version 2.01
- English
- Tested on Windows Media center and XP SP 2
- Save game Attached

When completing the final puzzle(launching buffoon to sponge, drawing door with fingus, and then opening handle with winkle) the actors leave through the door, the game shows a loading screen, and then exits. I can very briefly see an error in the scumm dosbox which looks as though it is saying there is a missing track, although its hard to be sure of this due to how fast it blinks by.

Ticket imported from: #1634250. Ticket imported from: bugs/3001.

Attachments (1)

gob2.s06 (3.0 KB ) - added by SF/exofreeze 13 years ago.
gobliins savegame

Download all attachments as: .zip

Change History (6)

by SF/exofreeze, 13 years ago

Attachment: gob2.s06 added

gobliins savegame

comment:1 by SF/exofreeze, 13 years ago

Summary: No EndingGOB2: No Ending

comment:2 by SF/exofreeze, 13 years ago

edit: I have confirmed the exact error message on exit.
Track g1final not found!

comment:3 by sev-, 13 years ago

Owner: set to DrMcCoy

comment:4 by DrMcCoy, 13 years ago

Resolution: fixed
Status: newclosed

comment:5 by DrMcCoy, 13 years ago

Hmm, seems like that track is really missing (the original executable just continues playing the last screen's track). I've changed CDROM::startTrack() to just warn without exiting when a track isn't found now...

Note: See TracTickets for help on using tickets.