Opened 13 years ago

Closed 13 years ago

#2942 closed defect (fixed)

WINCE: BS2 Using items

Reported by: SF/iancampbell79 Owned by: SF/knakos
Priority: normal Component: Engine: Sword2
Keywords: Cc:
Game: Broken Sword 2

Description

Just started playing BS2 under 0.9.1. When I try to use the panties with the the cylinder at the beginning of the game it crashes to the debug screen with:

Assetion failed h <= MAX_MOUSE_H (..\..\backends\wince\wince-sdl.cpp, 1671)

Have tried using other items with the cylinder and other objects and get this message as well, so it seems to be happening when any item is used on any object.

Save game attached.

Ticket imported from: #1609058. Ticket imported from: bugs/2942.

Attachments (1)

sword2.000 (237 bytes ) - added by SF/iancampbell79 13 years ago.
Save game at the first point you need to use an item

Download all attachments as: .zip

Change History (10)

by SF/iancampbell79, 13 years ago

Attachment: sword2.000 added

Save game at the first point you need to use an item

comment:1 by sev-, 13 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by eriktorbjorn, 13 years ago

To recapitulate what I wrote on the forum (which is unreachable at the moment, so I can't quote it verbatim), almost seven months ago I cleaned up the BS2 engine a bit, removing a hack that restricted the maximum size of a mouse cursor to 80x80 pixels. That used to be a limitation in the SDL backend, but isn't any more. (Though the MAX_MOUSE_W / MAX_MOUSE_H constants are still in sdl-common.h.)

At the time, I warned (both in commit message and on the scummvm-devel mailing list) that this could cause problems with backends that still had the limitation. I guess the WinCE backend wasn't updated.

comment:3 by eriktorbjorn, 13 years ago

Owner: set to SF/knakos
Summary: BS2 Using itemsWINCE: BS2 Using items

comment:4 by SF/knakos, 13 years ago

Note: Dupe #1637638 exists.

comment:5 by SF/klastes, 13 years ago

I have the same problem. I'm playing Broken Sword II under scummvm 0.9.1. on Fujitsu-Siemens Pocket LOOX 720 and when I try to use item with the the cylinder at the beginning of the game it crashes to the debug screen with: Assetion failed h <= MAX_MOUSE_H (..\..\backends\wince\wince-sdl.cpp, 1671) I have tried to pass this room on PC version and transfer savegame to PPC. POCKET SCUMMVM crash on the second room when I trying to use item with door. Please solve this problem.

comment:6 by SF/knakos, 13 years ago

please check out the latest svn build in the forums for this and report.

comment:7 by SF/knakos, 13 years ago

Status: newpending

comment:8 by SF/knakos, 13 years ago

Resolution: fixed
Status: pendingclosed

comment:9 by SF/knakos, 13 years ago

Ian Campbell reports this as fixed in private communication. thanks.

Note: See TracTickets for help on using tickets.