Opened 14 years ago

Closed 14 years ago

Last modified 21 months ago

#2929 closed defect (wontfix)

[0.9.x] doesn't build with gcc 2.95

Reported by: SF/fizzet Owned by: fingolfin
Priority: normal Component: Port: Linux
Keywords: Cc:
Game:

Description

scummvm 0.9.0 and 0.9.1 both fail to build with gcc 2.95. Find attached the relevant extracts from the build log for 0.9.1.

Ticket imported from: #1602835. Ticket imported from: bugs/2929.

Attachments (1)

scumm_err.log (5.6 KB ) - added by SF/fizzet 14 years ago.
scummvm 0.9.1 build log extracts

Download all attachments as: .zip

Change History (7)

by SF/fizzet, 14 years ago

Attachment: scumm_err.log added

scummvm 0.9.1 build log extracts

comment:1 by sev-, 14 years ago

Which OS are you using that you're forced to this ancient GCC version?

comment:2 by SF/fizzet, 14 years ago

The problem isn't my OS (Linux), but the fact that the gcc people make their product iterations ABI-incompatible and thus make upgrading a system a real pain...

comment:3 by fingolfin, 14 years ago

Well, I still don't consider this a bug. Feel free to file a feature request and we'll consider trying to make GCC 2.95 work again. Or even better, submit patches (if you are able to, I mean). As it is, supporting ancient and outdated compilers is far from the top of our priority list...

comment:4 by fingolfin, 14 years ago

Owner: set to fingolfin
Resolution: wontfix
Status: newclosed

comment:5 by fingolfin, 14 years ago

Though you might want to try building HEAD SVN instead, it might work better.

comment:6 by digitall, 21 months ago

Component: Port: Linux
Note: See TracTickets for help on using tickets.