Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2922 closed defect (fixed)

SIMON2: Crash while talking to Bingo Bongo

Reported by: SF/oncer Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 2

Description

ScummVM 0.9.1 (Oct 30 2006 16:52:27)
Debian unstable
Simon the Sorcerer Talkie German/Windows/CD
Subtitles enabled

When I talk to bingo bongo for the first time (savegame included), at the first selection choose the last line, at the next selection the third from the top ("... und komme von der Einwanderungsbehörde"), Simon says his line as normal...
... and THEN the console pops up and says "ERROR: Invalid VGA opcode '207' encountered".
When I try to return to the game, it crashes immediately.

Ticket imported from: #1600999. Ticket imported from: bugs/2922.

Attachments (1)

simon2.003 (811 bytes ) - added by SF/oncer 13 years ago.
Savegame at the specified position in the game

Download all attachments as: .zip

Change History (6)

by SF/oncer, 13 years ago

Attachment: simon2.003 added

Savegame at the specified position in the game

comment:1 by SF/oncer, 13 years ago

Owner: set to Kirben

comment:2 by SF/oncer, 13 years ago

Oh, and one thing: When I type "sub" in the console after the crash it tells me "Subroutine 5122". Maybe this helps?

comment:3 by Kirben, 13 years ago

The problem is specific to the German version of game, and only occurs when subtitles are enabled.

The problem occurs in the original version too, but a work around might be possible.

comment:4 by Kirben, 13 years ago

This is another case of extra long strings, which cause the charset image data to be writen beyond the zone's bounds (in renderString) and into the next zone, which is where the video script is stored.

Actually a regression, since we already have a work around for this problem, which was broken when support for the Feeble Files was added in past.

Fixed in ScummVM 0.10.0svn.

comment:5 by Kirben, 13 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.