Opened 13 years ago

Closed 11 years ago

#2918 closed defect (fixed)

FW: Missing sound

Reported by: eriktorbjorn Owned by: sev-
Priority: low Component: Engine: Cine
Keywords: Cc:
Game: Future Wars

Description

Latest SVN snapshot
English version

When the scaffolding (first room) moves up, there should be a sound effect. With ScummVM, there isn't.

Ticket imported from: #1599270. Ticket imported from: bugs/2918.

Change History (7)

comment:1 by sev-, 13 years ago

Owner: set to sev-

comment:2 by fingolfin, 13 years ago

Priority: normallow

comment:3 by fingolfin, 13 years ago

Doesn't sound that criticial, thus I am lowering the priority.

comment:4 by cyxx, 13 years ago

The sound should now be played with latest SVN, although it's not exactly similar to the original.

comment:5 by cyxx, 13 years ago

I backported some of my latest changes to the original cinE code and with it, the sound is repeated "correctly", just like the original.

Looks like the problem is due to version of the adlib emulator used by ScummVM (there are similar problems with the soundfx songs but this is already known, I guess).

So, to me, this isn't an "engine bug" anymore.

comment:6 by sev-, 11 years ago

Resolution: fixed
Status: newclosed

comment:7 by sev-, 11 years ago

With introduction of new adlib emu from dosbox the sound is there now. Closing.

Note: See TracTickets for help on using tickets.