Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2908 closed defect (fixed)

TOUCHE: Crashes at the beginning

Reported by: SF/kosuan Owned by: cyxx
Priority: normal Component: Engine: Touche
Keywords: Cc:
Game: Touché: The Adventures of the Fifth Musketeer

Description

Scumm svn version Nov. 14th.

at start scumm shows: 'unknown version of the game, please report, ect....

game crashes every time i tried it, - maybe at beginning of the speech / talks ???

It is an German/French version of the game - that means english talkie with german subtitles

It is the CD - version

- The english (floppy) - Version without speech (about 20 MB 'big') runs fine so far ...

Win 98 SE, Duron 800MHz, Ati Radeon 7000

The same happens on Mac OS 10.3 Macmini, scumm Version from Nov. 11th.

Thanks for including touche, i use scummVM since Version 6.1 and have every LucasArt title and most of the rest.

kosuan

P.S. you'll find me in the forum soon ...

Ticket imported from: #1597277. Ticket imported from: bugs/2908.

Change History (10)

comment:1 by fingolfin, 14 years ago

Owner: set to SF/chrilith
Summary: Crashes at the beginningTOUCHE: Crashes at the beginning

comment:2 by Kirben, 14 years ago

Owner: changed from SF/chrilith to cyxx

comment:3 by cyxx, 14 years ago

Could you report the information ScummVM display on startup ? It should give you a filesize and a md5 checksum.

Regarding the "crash", could you run ScummVM in debug mode and redirect the output to a file, like this :

scummvm.exe -d9 --debugflags=engine,resource,opcodes touche > run.log

... and attach the resulting file to this tracker item ?

Thanks

comment:4 by cyxx, 14 years ago

Status: newpending

comment:5 by cyxx, 14 years ago

Could you try again with the next daily snapshot ?

comment:6 by SF/kosuan, 14 years ago

Status: pendingnew

comment:7 by SF/kosuan, 14 years ago

I tried to start the debugger but it did not work in Touche, in other games it worked fine. This is what ScummVM diplays at start of the game:

Using configuration file: C:\WINDOWS\scummvm.ini Looking for touche Trying to start game 'Touche: The Adventures of the Fifth Musketeer' Datafile size (26625537) and MD5 (be2ae6454b3325e410946f2322547cd4) are unknow ! Please report the details (language, platform, etc.) of this game to the Scumm

I will try now the latest snapshot on my Win 98 machine and tell you later how it works.

kosuan

comment:8 by SF/kosuan, 14 years ago

Hi, i have tried now the latest snapshot - Win32 Nov.18 th. - and 'Touche' runs fine. Doesn't crash anymore - well done !! If I may find some more bugs, i will report them here. Have a nice day,

kosuan

comment:9 by cyxx, 14 years ago

Resolution: fixed
Status: newclosed

comment:10 by cyxx, 13 years ago

I noticed that I haven't extracted the charset data for the german version. As I need the original game executable (touche.exe) to do that, would it be possible for you to attach this file to this bug report ? Thanks.

Note: See TracTickets for help on using tickets.