Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2904 closed defect (fixed)

SYMBIAN: detection problems in SAGA engine

Reported by: sev- Owned by: sev-
Priority: normal Component: Engine: SAGA
Keywords: Cc:
Game: Inherit the Earth

Description

ITE doe not work on SymbianOS build. Tested on UIQ3,
0.9.1 release.

For DOS full game and Windows demo (I'm sure other
games will give same result) I get following:

- detection goes well and game gets added with proper
name and target name
- attempt to run it gives this error message:
"SagaEngine:loadGame wrong gameNumber" which should
never happen unless there is weird thing with md5s.

You can download ITE demo from www.wyrmkeep.com

Ticket imported from: #1595951. Ticket imported from: bugs/2904.

Change History (12)

comment:1 Changed 13 years ago by sev-

Summary: ITE: Symbian. Doesn't work at allSYMBIAN: detection problems in SAGA engine

comment:2 Changed 13 years ago by anotherguest

Have check the code for the detection and see if there are any alignment issues or other which might affect this.

comment:3 Changed 12 years ago by fingolfin

Status: newpending

comment:4 Changed 12 years ago by fingolfin

What is the status of this item? In particular, note that the detection code underwent some changes recently.

comment:5 Changed 12 years ago by sev-

No, there were no detection code changes in SAGA engine. On the contrary, AdvancedDetector came from this engine. It occurs with me on 0.9.1 and there is no alignment or endianness-depended code in any of our detectors, i.e we read game data byte by byte to calculate md5 and that's all.

anotherguest, currently 0.9.1 does not detect any SAGA game for me, so you may just grab its demo from www.wyrmkeep.com/ite and test. Or update our svn builds page with new set and I can test it for you.

comment:6 Changed 12 years ago by sev-

Status: pendingnew

comment:7 Changed 12 years ago by anotherguest

I have tested the ITE demo on the latest SVN build on a UIQ3 P990 and it worked fine. Not sure what might have gone with the MD5 in the 0.9.1 build. Is there any interrest of rebuilding another 0.9.1 or continuing on the SVN path which works?

comment:8 Changed 12 years ago by sev-

Owner: changed from anotherguest to sev-

comment:9 Changed 12 years ago by sev-

Of course, do not mess with 0.9.0 branch, with SVN only. I will test the latest SVN build soon and will report.

comment:10 Changed 12 years ago by fingolfin

Any news on this one?

comment:11 Changed 12 years ago by sev-

Works now.

comment:12 Changed 12 years ago by sev-

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.