Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2897 closed defect (fixed)

WINCE: BS1: WinCE menu problems

Reported by: SF/iancampbell79 Owned by: SF/knakos
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

When I first run the game everything work fine, until
I use the menu to save my game.

1. Once I have done this, my mapped button to hide
the keyboard will cycle through
keyboard/icons/nothing as normal except sometimes the
icons are displayed as blank, and only appear when
you tap where they should be.

2. No matter whether 1. happens I can then no longer
get into the menu. When I click the menu icon the
menu flashes up and then disappears again in a
fraction of a second. This means that the only way to
get out of the game is to reset the device, and that
I can only save once per gaming session.

I have an IPAQ 2790, WM5, QVGA

It appears to be the device because I have checked
0.8.2 which did work on my old device, but that
exhibits the same behaviour. Could this be related
to the button mapping problem?

Ticket imported from: #1593299. Ticket imported from: bugs/2897.

Change History (7)

comment:1 by SF/iancampbell79, 13 years ago

Summary: Menu Problems v9.1BS1 Menu Problems v9.1

comment:2 by sev-, 13 years ago

Summary: BS1 Menu Problems v9.1BS1: WinCE menu problems

comment:3 by sev-, 13 years ago

This was reported for 0.9.1

comment:4 by SF/knakos, 13 years ago

Owner: set to SF/knakos
Summary: BS1: WinCE menu problemsWINCE: BS1: WinCE menu problems

comment:5 by SF/knakos, 13 years ago

The toolbar state var is junked after forcing the keyboard in vga devices.

comment:6 by SF/knakos, 12 years ago

fixed in commit r26683.

comment:7 by SF/knakos, 12 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.