Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2896 closed defect (fixed)

SIMON1: Crash in Dwarf Cave

Reported by: SF/mthreepwood Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

Simon1 (Windows) MacOSX 10.2.8 0.10.0svn 11/5/06

After giving the beer to the dwarf in the cave, and Simon puts the beer down, ScummVM crashes with this error:

engines/agos/gfx.cpp:835: failed assertion `READ_BE_UINT16(&((AnimationHeader_Simon *) p)->id) == vgaSpriteId' Abort

Saved Game Attached. Just give the guard the beer.

Ticket imported from: #1592914. Ticket imported from: bugs/2896.

Attachments (1)

simon1.008 (872 bytes ) - added by SF/mthreepwood 14 years ago.
Saved Game before Crash

Download all attachments as: .zip

Change History (4)

by SF/mthreepwood, 14 years ago

Attachment: simon1.008 added

Saved Game before Crash

comment:1 by Kirben, 14 years ago

An extremely old regression, caused by removal of code long ago.

comment:2 by Kirben, 14 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:3 by Kirben, 13 years ago

Component: Engine: AGIEngine: AGOS
Game: Leisure Suit Larry 1Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.