Opened 13 years ago

Closed 13 years ago

Last modified 12 months ago

#2875 closed defect (duplicate)

SYMBIAN: SCUMM crash at screen moving

Reported by: SF/webin Owned by: fingolfin
Priority: normal Component: Port: Symbian
Keywords: Cc:
Game:

Description

-ScummVM version 0.9.0 for Symbian 60 v2 binary
-Reported bug in Monkey Island 2 and IJ and the fate
of atlantis (reported in different versions, italian
and spanish)

The program always crash in two similar cases, when in
the game there is an automatic scroll of the screen,
to let the player see something near the edge of the
screen.

For example it always happens in these two scenes:

-MK2: In the Booty island, at the reef, when we want
to see under the reef, the program crashes because
it's not able to scroll the screen

-IJ fate of atlantis: In Algeri, in the desert scene
when you ride a camel, when you try to go in the next
screens where you should find the camel-riding guards,
the program crashes for the same reason.

I tried playing both games with scummvm-0.8.1-s60-
v2b.sis and it works well even in the scenes i
reported.

Hope you can fix this bug (tested on 7610 and 6600) ,
good work!

Ticket imported from: #1581342. Ticket imported from: bugs/2875.

Change History (7)

comment:1 by fingolfin, 13 years ago

Owner: set to anotherguest
Summary: Scumm 0.9.0 symbian = crash at screen movingSYMBIAN: SCUMM crash at screen moving

comment:2 by fingolfin, 13 years ago

This bug is likely caused by grabRawScreen() not being implemented properly. See bugs #1513002, #1531983, #1581342, #1594636.
We should first establish that this is indeed the cause; then make sure it is fixed in the SVN trunk. In addition, porters might want to make a 0.9.1a release with
this issue fixed.

comment:3 by SF/zero-2-one, 13 years ago

In Dott (German / Talkie) it is the same problem when you have to wash the wagon and the clouds shoud appear. On my N73 the latest version of ScummVM crashes without any message, the Scumm gets closed and I am back at my phone screen.

I think it is the same problem

grz zero

comment:4 by bluegr, 13 years ago

Also look at bug report #1600313 (and #1616233, which seems to be a dupe)

comment:5 by fingolfin, 13 years ago

Owner: changed from anotherguest to fingolfin
Resolution: duplicate
Status: newclosed

comment:6 by fingolfin, 13 years ago

Closed as duplicate of bug #1513002.

comment:7 by digitall, 12 months ago

Component: --Unset--Port: Symbian
Note: See TracTickets for help on using tickets.