Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2870 closed defect (fixed)

WINCE: GCC Build: CoMI crashes

Reported by: SF/frank_m24 Owned by: SF/knakos
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Starting CoMI causes the PocketPC GCC Build to crash. The Program exits without an error message. I tried different scalers, no difference. The top of the Today Screen (Start Menu, Clock ...) is only a black bar after the crash. Nothing is accessible. A Soft Reset solves this issue.

PDA: Dell Axim X50v with Windows Mobile 5 ScummVM: PocketScumm Oct 8 2006 19:52:52 (The GCC Build) German CoMI with OGG compressed audio.

Ticket imported from: #1576242. Ticket imported from: bugs/2870.

Change History (6)

comment:1 by fingolfin, 13 years ago

Owner: set to SF/knakos
Summary: CoMI crashes WinCE GCC BuildWINCE: CoMI crashes

comment:2 by SF/knakos, 13 years ago

There seems to be a deeper cause for all games that are now unplayable (like gob, simon or bass engines) as the gp2x port suffers from exactly the same symptoms in the trunk, but not in the 0.9.0 branch. It may be something like alignment problems.

comment:3 by SF/knakos, 13 years ago

Summary: WINCE: CoMI crashesWINCE: GCC Build: CoMI crashes

comment:4 by fingolfin, 13 years ago

Maybe #pragma pack doesn't work correctly? Can you make a precise list of games that stopped working? Might help in narrowing down the cause of this.

comment:5 by SF/knakos, 13 years ago

no problems in the svn build (http://forums.scummvm.org/viewtopic.php?t=3518). closing

comment:6 by SF/knakos, 13 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.