Opened 18 years ago

Closed 17 years ago

#286 closed defect (fixed)

DOTT: Flickering Chron-O-John

Reported by: (none) Owned by: eriktorbjorn
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

I downloaded the Win32 binaries on Saturday 18th in order to get Day of the Tentacle running on WinMe (what, use LucasArts' patches and the original .exe? Never...) Works great just about everywhere, except this one glitch. Putting the hamster in the generator in Dr. Fred's lab makes both wheels and the hamster vanish while the animation runs (ooh, look at him go!) The sparks fly at the top of the gadget, and the wheels and hamster reappear afterwards, so all's OK.

I didn't notice this with ScummVM 0.1, which I used to play right through DotT in Linux a while back. Not sure if I ever used the hamster with the generator in Bernard's time, though - only with Laverne. And I didn't play through far enough in 0.2 under Windows to try it with Laverne. Oh well.

Point being, have Bernard use the Hamster with the Generator, and the animation messes up.

Ticket imported from: #558310. Ticket imported from: bugs/286.

Attachments (2)

tentacle.s06 (52.8 KB ) - added by fingolfin 18 years ago.
Flickering Chron-O-John
tentacle.s20 (50.7 KB ) - added by SF/painelf 18 years ago.
This one works for me

Download all attachments as: .zip

Change History (22)

comment:1 by (none), 18 years ago

Logged In: NO

maybe related to [557259] and [552314] ???

comment:2 by SF/ender, 18 years ago

I'm still too busy with work this week - can you take a look at this one, or bug Yaz about it? It's most likely the result of one of his costume renderer hacks for Indy3/Zak.

Oh, and I think you should combine all these bugs into a single new "Disappearing animations" bug, and close all the others.

Thanks :)

comment:3 by SF/ender, 18 years ago

Owner: set to fingolfin

comment:4 by fingolfin, 18 years ago

Doing that: other places this bug appears:

* In DOTT, when you connect one of the Chron-O- John's back to it's power source, it will "blink" out of view and then become visible again

* In FOA near the beginning, when Indy talks to Sophia and puts the bead into the mouth of the necklace, both Indy and Sophia disappear for some time.

comment:5 by fingolfin, 18 years ago

Component: Engine: SCUMM--Unset--
Game: Day of the Tentacle
Priority: normallow
Summary: Hamster generator vanishes in Win32Disappearing animations

comment:6 by fingolfin, 18 years ago

I can reproduce the bug in Indy, and with the chron-o- johns; however, can't reproduce it with the hamster - it appears just fine there for me.

comment:7 by fingolfin, 18 years ago

It seems this is linked to the lightning effect. My guess is that the screen is redrawn but not the actors, until after some delay. In all cases this occurs, lightning is involved.

comment:8 by fingolfin, 18 years ago

Yet another place where it occurs: in Indy IV, in the moment you put Sophias necklace into the golden box, Sophia will disappear for a moment.

Also once more an unkScreenEffect5(0) occurs shortly before, I wonder if there is a relation with this after all?

comment:9 by fingolfin, 18 years ago

Yet another place where it occurs: in Indy IV, in the moment you put Sophias necklace into the golden box, Sophia will disappear for a moment.

Also once more an unkScreenEffect5(0) occurs shortly before, I wonder if there is a relation with this after all?

comment:10 by fingolfin, 18 years ago

OK I found the solution & a fix for this in Indy IV: the problem was that we were doing a full screen redraw - but we didn't redraw actors upon a full redraw! I now enforce actor redrawing upon a full redraw. Works fine so far.

However it doesn't fix the Chron-O-John - I am not sure they are the same, and in fact I am not even sure that the chron-o-john behaviour is actually wrong - I can't test it right now, but isn't it possible that it's meant to flicker - after all it's a time machine. I will play the original Dott to check how that scene should look.

comment:11 by fingolfin, 18 years ago

Component: --Unset--Engine: SCUMM
Game: Day of the Tentacle
Owner: fingolfin removed
Summary: Disappearing animationsDOTT: Flickering Chron-O-John

comment:12 by fingolfin, 18 years ago

Save game for DOTT attached. Just plug in the battery.

by fingolfin, 18 years ago

Attachment: tentacle.s06 added

Flickering Chron-O-John

comment:13 by fingolfin, 18 years ago

Stupid browser garbled the attachment

by SF/painelf, 18 years ago

Attachment: tentacle.s20 added

This one works for me

comment:14 by (none), 18 years ago

Logged In: NO

the reason why some savegames might not work, are the different localizations of the games. i tried the savegames and the display english text in the german version of the game, after that the game crashes.

comment:15 by SF/painelf, 18 years ago

I've stepped through the script. I'm fairly certain that we have correct behavior: the cron-o-johns are supposed to flicker.

comment:16 by SF/dfabulich, 17 years ago

I just played through to that part of the original DOTT, US talkie CD. The current ScummVM flickering chron-o-john behavior is *not* correct. The john is supposed to... uh. I guess you'd say it convulses twice as you plug it in. The ScummVM behavior is definitely not correct as of ScummVM 0.2.81 CVS, Built on Nov 13 2002 17:03:53.

I can attach my savegame file from DOTT if anybody cares to double-check. My tentacle.exe says that it's: "Interpreter Version 6.4.2 (Jun 02 1993 18:04:22)"; I think you'd need to have the same exact version to be compatible.

comment:17 by SF/dfabulich, 17 years ago

Well, I *would* attach an original saved game, but I can't seem to attach files to this bug. :(

comment:18 by eriktorbjorn, 17 years ago

I didn't expect it, since I was really looking to fix another bug, but it seems patch #649358 ("DOTT: Fix for some animation glitches") fixes this. Could someone please verify?

comment:19 by eriktorbjorn, 17 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:20 by eriktorbjorn, 17 years ago

I've been told that the bug is indeed fixed, and that the patch will be in 0.3.0.

Note: See TracTickets for help on using tickets.