Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2855 closed defect (invalid)

ZAK V2: London guard walkpath bug

Reported by: SF/glo_kidd Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: original Cc:
Game: Zak McKracken

Description

- This was originally tracker item [ 1508005 ] and has
been seperated into individual reports at Fingolfins
request.
- ScummVM ver.: 0.9.0pre(jun 17 2006)win32snapshot
- Bug Details: Zak walks behind the guard in london
instead of in front of him similarly to the previously
posted katmandu guard bug
- How to Re-create:From your position in the savegame
Walk to airport
- Lang.: English
- Ver.: 3.5 floppy version from the lucasarts classic
adventures collection
- a savegame is attached

Hope this helps guys, thanks again

Ticket imported from: #1571747. Ticket imported from: bugs/2855.

Attachments (1)

zak.s20 (9.2 KB) - added by SF/glo_kidd 13 years ago.
london guard bug

Download all attachments as: .zip

Change History (8)

Changed 13 years ago by SF/glo_kidd

Attachment: zak.s20 added

london guard bug

comment:1 Changed 13 years ago by fingolfin

Very odd. The drunken sentry is place by the scripts at coords (0,63) (in char coordinates). And there is a horizontal walkbox with y-coordinates 63, so that matches. And Annie walks along that line. And since she has actor id 2, less than the actor id (10) of the sentry, she is drawn first, and thus, behind him.
So either we place her incorrectly (but then the walkbox would be wrong, too??), or maybe the actor drawing order is different in Zak after all... ?

comment:2 Changed 13 years ago by SF/glo_kidd

hi Fingolfin, I just checked with the current win32 svn snapshot(Feb 24 2007,12:28:47)and can confirm that this is stiil present in the ENG zak V2. Hope this helps a bit, sorry i cant help more. Let me know if you need more testing

comment:3 Changed 12 years ago by fingolfin

Could it be that the drunken guard is simply in the wrong spot? Shouldn't he be sitting in his guard house? I don't recall how this was in the original engine, and I can't test it myself, unfortunately :-(.

comment:4 Changed 12 years ago by bluegr

This is not a bug, just tried it with the original and the behavior is exactly the same, i.e. Zak will walk behind the guard when he's placed next to the fence and walks towards the guard. I got a save game of this place too, if you need it. I've tested this with the floppy version, the same as the original poster used

Please close this, it's not a bug, the behavior is the same in the original interpreter

comment:5 Changed 12 years ago by Kirben

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:6 Changed 12 years ago by fingolfin

Thanks for testing this!

comment:7 Changed 12 years ago by Kirben

Keywords: original added
Note: See TracTickets for help on using tickets.