Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2853 closed defect (invalid)

ZAK V2: Katmandu guard walkpath bug

Reported by: SF/glo_kidd Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: original Cc:
Game: Zak McKracken

Description

- This was origially tracker item [ 1508005 ] and has
been seperated at Fingolfins request
- ScummVM ver.: 0.9.0pre(jun 17 2006)win32snapshot
- Bug Details: in katmandu zak will walk behind the
gurus guard instead of in front of him
- How to Re-create: just walk past guard
- Lang.: English
- Ver.: 3.5 floppy version from the lucasarts classic
adventures collection
- A savegame has been attached

Hope this helps a little more, sorry about posting all
5 of these bugs in the original tracker item

Ticket imported from: #1571707. Ticket imported from: bugs/2853.

Attachments (1)

zak.s18 (8.5 KB) - added by SF/glo_kidd 13 years ago.
katmandu guard bug

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by SF/glo_kidd

Attachment: zak.s18 added

katmandu guard bug

comment:1 Changed 13 years ago by fingolfin

Are you sure this is a bug, i.e. did you compare this to the original? I can walk both in front and behind the guru guard, depending on how close to the wall I stay.

comment:2 Changed 13 years ago by SF/glo_kidd

Hi Fingolfin, I just checked it out again with the daily snapshot. Zaks movement now is exactly as you describe. I cant quite remember but i think zak might have been stuck walking along the back of the wall back when i reported this. To be quite honest i dont think that this is a bug anymore, actually its sort of a neat trick :).I havent been abe to get zak running in dosbox to test against the original executeable to see if its there originally.
Ultimately, if there was a problem it seems fixed now :) Thanks

comment:3 Changed 13 years ago by SF/glo_kidd

oops just realized i forgot to say i tested with the win32 snapshot(feb 04 07, 12:28:47)

comment:4 Changed 13 years ago by SF/glo_kidd

oops just realized i forgot to say i tested with the win32 snapshot(feb 04 07, 12:28:47)

comment:5 Changed 12 years ago by bluegr

This is not a bug, just tried it with the original and the behavior is exactly the same, i.e. Zak will walk behind the guard when he's placed next to the wall and walks towards the guard. I got a save game of this place too, if you need it. I've tested this with the floppy version, the same as the original poster used

Please close this, it's not a bug, the behavior is the same in the original interpreter

comment:6 Changed 12 years ago by Kirben

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:7 Changed 12 years ago by fingolfin

Thanks for testing this with the original interpreter, very helpful!

comment:8 Changed 12 years ago by Kirben

Keywords: original added
Note: See TracTickets for help on using tickets.