Opened 13 years ago

Closed 13 years ago

Last modified 10 months ago

#2850 closed defect (fixed)

GUI: crash when pressing "delete" at the end of the name

Reported by: SF/richiefs Owned by: fingolfin
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

When editing a game settings in the gui,
press "delete" when at the end of the game name -->
scummvm crashes with error:

Assertion failed: p < _len, file common/str.cpp, line
217

Ticket imported from: #1570189. Ticket imported from: bugs/2850.

Change History (4)

comment:1 Changed 13 years ago by eriktorbjorn

This looks like a recent regression. Before revision 24043,
String::deleteChar() silently ignored attempts to remove
characters outside of the string, so it doesn't happen in
the 0.9 branch.

comment:2 Changed 13 years ago by eriktorbjorn

Owner: set to fingolfin

comment:3 Changed 13 years ago by fingolfin

Resolution: fixed
Status: newclosed

comment:4 Changed 10 months ago by digitall

Component: GUI
Note: See TracTickets for help on using tickets.