Opened 18 years ago

Closed 18 years ago

Last modified 18 years ago

#284 closed defect (fixed)

FOA: Indy doesn't stop moving

Reported by: SF/trinity78 Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Game: Indiana Jones 4 - German Floppy Version OS: Windows 2000 Adv. Server SP 2 ScummVM: DailyBuild from 2002/05/19

Bug:

This is a minor animation glitch. After a short ingame cutscene, indy keeps on running instead of stop moving. Savegame attached.

Ticket imported from: #558236. Ticket imported from: bugs/284.

Attachments (2)

ATLANTIS.s08 (54.2 KB ) - added by SF/trinity78 18 years ago.
indyrun.jpg (54.2 KB ) - added by SF/trinity78 18 years ago.
screenshot

Download all attachments as: .zip

Change History (12)

by SF/trinity78, 18 years ago

Attachment: ATLANTIS.s08 added

comment:1 by fingolfin, 18 years ago

I can't use the save game in my version (probably an endian issue in your save game code); in any case, if you tell me what scene this is exactly, maybe I can reproduce it here anyway (and hence look into the issue :-)

comment:2 by fingolfin, 18 years ago

Summary: Indy doesn't stop movingFOA: Indy doesn't stop moving

by SF/trinity78, 18 years ago

Attachment: indyrun.jpg added

screenshot

comment:3 by SF/trinity78, 18 years ago

ok i've upload a screenshot of it. this just after the ingame cutscene and indy keeps on running at the same spot.

comment:4 by fingolfin, 18 years ago

Owner: set to fingolfin

comment:5 by fingolfin, 18 years ago

Resolution: fixed
Status: newclosed

comment:6 by fingolfin, 18 years ago

I added a workaround to CVS.

comment:7 by eriktorbjorn, 18 years ago

Which FOA path was this bug in? I'm trying to fix a possibly related bug in Loom CD, and I'd like to check if my experimental fix takes care of this one too.

(Assuming I can reproduce it in the English talkie version, once I've removed the workaround.)

comment:8 by SF/trinity78, 18 years ago

you might wanna try the savegame if it still works, also take a look at the screenshot.

it was the single (puzzle) path.

comment:9 by eriktorbjorn, 18 years ago

Which FOA path was this bug in? I'm trying to fix a possibly related bug in Loom CD, and I'd like to check if my experimental fix takes care of this one too.

(Assuming I can reproduce it in the English talkie version, once I've removed the workaround.)

comment:10 by eriktorbjorn, 18 years ago

Gah, how did my question get re-posted?

Anyway, I have my doubts on whether the savegame from the German floppy version would work with the English CD version. But I have a boatload of old savegames, so I can probably dig up one that's close enough.

Note: See TracTickets for help on using tickets.