Opened 13 years ago

Closed 13 years ago

#2839 closed defect (fixed)

BS2: AmigaOS4: No video playback

Reported by: (none) Owned by: fingolfin
Priority: normal Component: Engine: Sword2
Keywords: Cc:
Game: Broken Sword 2

Description

ScummVM 0.10.0svn (Sep 26 2006 11:57:25)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

With the video files (be it the downloadable
MP2's or the reencoded DXA's) in a subdir OR
in the game's root dir, no video file is played.

I get a black screen with background music (NO
narrator dummy coming up here) with the EYE movie
and a narrator dummy with background sound and
speech with the INTRO ("This must be the place...
Professor Ubie's House...").

I also CANNOT skip the movies with ESC, there is
simply NO keyboard input processed or so it seems

Something HAS been fixed already, i couldn't use
the game with the video files placed in subdirs
before the OS4 backend fixes were made.

Broken Sword 2 - "Sold Out" Version (English)

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1565633. Ticket imported from: bugs/2839.

Change History (10)

comment:1 by (none), 13 years ago

Summary: AmigaOS4: No video playbackBroken Sword 2 - AmigaOS4: No video playback

comment:2 by fingolfin, 13 years ago

Summary: Broken Sword 2 - AmigaOS4: No video playbackBS2: AmigaOS4: No video playback

comment:3 by (none), 13 years ago

Just for the record, it's not gone, but has changed

Videos in MP2

1. With todays build i can watch the "eye" movie, but i
still get the "Narrator dummy screen" on the intro movie.
I CAN skip this intro again, but when i press ESC i have
to wait until the background music stops (voice acting is
already stopped) to get ScummVM to skip to the game.

This is with all of the video files in the main dir
(together with the rest of the files)

2. Placing the video files into a subdir called "VIDEO",
i get the "Broken Sword: Cannot find SCRIPTS.CLU" error
message ... see bug #1548205

3. Placing the videos in a subdir called "VIDEOS", i get
the normal playback (that is with the MP2 format) and can
play the game as it should be

Videos in DXA

1. Like above

2. Normal playback of the .dxa video files, game works

3. "Broken Sword: Cannot find SCRIPTS.CLU" error message

Funny thing is the "randomness" between the naming of the
subdir AND the format of the video files, there definitely
seems to be something wrong with file/path handling here.
(Amiga OS4/MorphOS-only, maybe)

OS4 porter is informed about that, just to notice everyone
else, maybe someone has an idea or stumbled over some
suspicious code the other day which MAY trigger this
behaviour!?

comment:4 by SF/capehill, 13 years ago

Hello,

I have installed the game files as told in the manual and
copied videos in the same directory.

I have the error "Cannot open SCRIPTS.CLU" when trying to
start the game for the first time. If I try again, it
starts. There is loud music but no video for a moment, and
then the intro movie starts, and finally the game starts.

If I try the demo, it may not start on the first attempt
either (Cannot open SCRIPTS.CLU) but when it starts, there
is the same loud music AND eye movie, but only music after
(no video) until the demo game starts.

Ok, this is a lousy bug report but I will try to find the
reason for this errational behaviour..

AmigaOS 4 build.

comment:5 by SF/capehill, 13 years ago

Hmm.. turns out I haven't installed BS 2 DEMO cutscene pack.
When I install that I probably get a playback with demo. (sorry)

comment:6 by SF/capehill, 13 years ago

Ok, I guess I found something related to starting problems.
Turns out that sometimes SCRIPTS.CLU is imagined to be a
directory (File:exists() returns false) and this causes an
error message in sword2's ResourceManager. I already changed
AmigaOS FS constructors and now I can start the game and
demo always with video playback too. I will check if
anything breaks now and make little patch.

comment:7 by (none), 13 years ago

With this patch from capehill, i can confirm that all
the issues i described are gone, game starts, videos
play.

I'm now even able to put the two speech.clu files into
a subdir SPEECH (which wasn't possible before) and the
game still runs and doesn't complain

Great work capehill

comment:8 by SF/capehill, 13 years ago

Can we close this one?

comment:9 by sev-, 13 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:10 by sev-, 13 years ago

Apparently patch #1573141 fixed it. It was accepted by
Fingolfin. Thanks, Juha.

Note: See TracTickets for help on using tickets.