Opened 13 years ago

Closed 13 years ago

#2833 closed defect (invalid)

COMI: Crash during Chapter 4 opening cutscene

Reported by: SF/cloney Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I'm running the latest SVN build of ScummVM on a G4 Powermac,
acquired and built at 15:26 GMT.

After finishing the swordfight with Rottingham, Chapter 4 starts up. The
chapter splash screen loads up OK, then the opening video begins to play.
Right when the island looms up through the clouds, ScummVM is crashing
with the following message:

ERROR: (7:327:0x24) : invalid seek request 38700 > 27844 (delta ==
17338)

Otherwise, all video sequences have been running OK. This was
happening with the previous build (dated Friday, I think), and the update
didn't fix it.

Will compressed SAN files make a difference to this? I can't remember if
these are compressed; if so, it was done about eight months ago with the
then current tools. If you let me know which .san file is relevant here, I
can put up an MD5.

Savegame attached.

Ticket imported from: #1560273. Ticket imported from: bugs/2833.

Attachments (1)

comi.s05 (82.9 KB ) - added by SF/cloney 13 years ago.
Savegame just after defeating Rottingham

Download all attachments as: .zip

Change History (6)

by SF/cloney, 13 years ago

Attachment: comi.s05 added

Savegame just after defeating Rottingham

comment:1 by eriktorbjorn, 13 years ago

I can't reproduce it on my Linux box, neither with
compressed video (which I did on June 10 2005, according to
the file time stamps), nor with the original one.

If you've compressed yours, each .san file should have a
corresponding .ogg or .mp3 file with the sound.

It's the wrecksan.san file, which is locaed on the second
CD. The MD5 sum for mine is 28fb6dbe5963aa28daf18584332ea0e9.

comment:2 by SF/cloney, 13 years ago

I compressed these SAN files a looong time ago (I was still running Linux -
file stamp shows April 2004). I think this was using an early version of
compress_san that didn't create a seperate audio file. I've never played
completely through the game with these compressed files, so they could be
bad.

(compressed wrecksan)
b3eb349ac904ede5018518d930a870aa wrecksan.san
Size: 12516820

I suspect it could be time to dig the COMI CDs out of the loft and recompress
the files using the new tools. Interesting that all the others have played OK,
though, like the opening for example:

(compressed opening.san)
ac2db909b0372a0a25be053f42a89e0a opening.san
Size: 57068778

comment:3 by eriktorbjorn, 13 years ago

To clarify, the MD5 sum I posted was for the uncompressed
wrecksan.san.

comment:4 by SF/cloney, 13 years ago

I've dug out the original CDs, and replaced the file with the original, the md5 of
which matches the one listed here. All tested OK.

This should be OK to close; sorry for wasting time!

comment:5 by eriktorbjorn, 13 years ago

Owner: set to eriktorbjorn
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.