Opened 13 years ago

Closed 13 years ago

Last modified 12 months ago

#2817 closed defect (worksforme)

WINCE: crash on VGA screen with 2x scaler - ScummVM 0.9.0a

Reported by: SF/rnegut Owned by: SF/knakos
Priority: normal Component: Port: WinCE
Keywords: Cc:
Game:

Description

Hardware environment: PocketPC Fujitsu-Siemens Loox
N560, cpu: XScale@624Mhz, screen: VGA (480x640), 20Mb
RAM free at ScummVM start-up. Both ScummVM and the
games reside on a 1Gb SD card.

Symptoms: Beneath a Steel Sky and Monkey Island 1&2 run
fine in portrait mode (taking up only about 1/4 of the
screen). After switching to 2x scaler, ScummVM starts
up fine in landscape mode, but all games crash
instantly with "unrecoverable exception" errors.

Crash-dumps:
scummvmCrash_06_09_2006_10_38_04.txt:
----------------------------------------
Exception Access Violation Flags 00000000 Address 00090410
Parameter 0 00000001
Parameter 1 1c5073b0
----------------------------------------
Context dump
R0=005d66fa R1=00000288 R2=00506eb0 R3=00000000 R4=00000012
R5=00506eb0 R6=00000500 R7=005d66fc R8=00000011 R9=000001b2
R10=ffffff3e R11=0043d270 R12=00000000
Sp=1c40f9c4 Lr=ffffff25 Pc=00090410 Psr=2000001f
----------------------------------------
Memory dump at 000903de
5e e3 11 00 00 0a 18 40
9d e5 01 e0 4e e2 02 50
a0 e1 00 00 54 e3 08 00
00 da 00 70 a0 e1 04 80
a0 e1 b2 30 d7 e0 01 80
58 e2 03 38 83 e1 00 30
85 e5 06 30 85 e7 04 50
85 e2 f8 ff ff 1a 01 00
80 e0 86 20 82 e0 00 00
5e e3 ee ff ff 1a f0 81
bd e8 0c 10 9f e5 04 00
9f e5 87 20 a0 e3 aa de
ff eb d8 20

scummvmCrash_06_09_2006_10_37_43.txt:
----------------------------------------
Exception Access Violation Flags 00000000 Address 00090410
Parameter 0 00000001
Parameter 1 1c507330
----------------------------------------
Context dump
R0=005d66ba R1=00000288 R2=00506e30 R3=00000000 R4=00000012
R5=00506e30 R6=00000500 R7=005d66bc R8=00000011 R9=000001ae
R10=ffffff42 R11=0043d270 R12=00000000
Sp=1c40f9ac Lr=ffffff27 Pc=00090410 Psr=2000001f
----------------------------------------
Memory dump at 000903de
5e e3 11 00 00 0a 18 40
9d e5 01 e0 4e e2 02 50
a0 e1 00 00 54 e3 08 00
00 da 00 70 a0 e1 04 80
a0 e1 b2 30 d7 e0 01 80
58 e2 03 38 83 e1 00 30
85 e5 06 30 85 e7 04 50
85 e2 f8 ff ff 1a 01 00
80 e0 86 20 82 e0 00 00
5e e3 ee ff ff 1a f0 81
bd e8 0c 10 9f e5 04 00
9f e5 87 20 a0 e3 aa de
ff eb d8 20

Ticket imported from: #1553313. Ticket imported from: bugs/2817.

Change History (6)

comment:1 by SF/rnegut, 13 years ago

Summary: crash on VGA screen with 2x scalercrash on VGA screen with 2x scaler - ScummVM 0.9.0a

comment:2 by SF/knakos, 13 years ago

Owner: set to SF/knakos
Summary: crash on VGA screen with 2x scaler - ScummVM 0.9.0aWINCE: crash on VGA screen with 2x scaler - ScummVM 0.9.0a

comment:3 by SF/knakos, 13 years ago

Initial investigation shows that this is a random crash.
This could be the cause of low memory conditions (btw,
other VGA ppc users have not reported such a problem).
Please try to increase the free RAM some more and run it
again. If this still does not work, it may be some further
clipping problems I discovered recently which may corrupt
memory and hence crash.

comment:4 by SF/knakos, 13 years ago

Resolution: worksforme
Status: newclosed

comment:5 by SF/knakos, 13 years ago

No idea about this one. On a 64 meg VGA emulator image
with: Total main: 29.50M, Program: 19.4M of which 8.11M in
use and 11.29 free, bass & mi1 & mi2 run OK, with a current
branch checkout. Please wait until 0.9.1 comes out.

comment:6 by digitall, 12 months ago

Component: --Unset--Port: WinCE
Note: See TracTickets for help on using tickets.