Opened 13 years ago

Closed 13 years ago

#2794 closed defect (invalid)

FEEBLE:Crash on Sam walk

Reported by: SF/rserral Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: The Feeble Files

Description

Hi, I think I just found a bug in scummvm while
playing The Feeble Files. I'm using the 4CD windows
English version with up to date SVN checkout:
ScummVM 0.10.0svn (Aug 26 2006 12:25:19)
Features compiled in: Vorbis FLAC MP3 ALSA zLib MPEG2
FluidSynth

The problem is when you try to walk with Sam the
robot to catch the native in the forest planet
(savegame included) the moment you click to move the
robot, the program ends with a Segmentation Fault.

I've tried it in a couple of machines with the same
problem:
Debian Testing
Debian Sid

As it seems to be related to sound I've tried with
the original voice?.wav and with the voice?.ogg
versions with the same result.

If you need more information don't hesitate to
contact me.

BR

Ticket imported from: #1547106. Ticket imported from: bugs/2794.

Attachments (1)

feeble.008 (980 bytes) - added by SF/rserral 13 years ago.
Feeble savegame

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by SF/rserral

Attachment: feeble.008 added

Feeble savegame

comment:1 Changed 13 years ago by Kirben

I'm unable to reproduce the crash with English 4CD version
in ScummVM SVN under Windows XP.

The sound effects are stored in the xxx3.VGA files, so a
corrupt file could cause a crash. Why do you suspect sound
is the cause though?

If you start ScummVM with a debug level of 3, you will see
the filenames mentioned as they are accessed. ie
scummvm -d3 feeble

Press the 'g' key when in game to filter out the other
debug output, when using debug level 3.

comment:2 Changed 13 years ago by SF/rserral

Oh! my, I just realized thanks to your post that I forgot
to copy the vga (lowercaps) files in the data1.cab file
when I first extracted them with wine.

Sorry for bothering you with such an issue, it is fixed
now!

BR

comment:3 Changed 13 years ago by Kirben

Owner: set to Kirben
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.