Opened 13 years ago

Closed 13 years ago

#2791 closed defect (fixed)

FREDDI1: MAC/Dutch CD not recognized

Reported by: SF/daniel9 Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: detection Cc:
Game: Freddi Fish 1

Description

I have a dutch Mac CD with this game and it is not
recognized. The MD5 codes are not in the list on the
website, so I will include them here:

Freddi Fish 1: The Case of the Missing Kelp Seeds (freddi)
Freddi Fish en het verhaal van de Verdwenen Zeewierzaadjes
Dutch
Macintosh version
6d1baa1065ac5f7b210be8ebe4235e49 Freddi (0)
df912cb5c96190d65dd7be3e9e3dc412 Freddi (1)
ea018e8f8af0a452cd88a8219ca7260b Freddi (2)
6daf76c1fe724ce6bf2e4c5175f39352 Freddi (3)
8e27aebf6d89f8576a08b58e216a6a90 Freddi (4)

ScummVM 0.9.0 build Jul 12, 2006
Platform: Mac OS X 10.4.7

I have a lot more unrecognized Humongous games, so if
this one can be included, I have a few others to add.

If you have any comments or questions, please keep in
mind that I entered Sourceforge just 30 minutes ago...

Ticket imported from: #1544908. Ticket imported from: bugs/2791.

Change History (11)

comment:1 Changed 13 years ago by fingolfin

Summary: Freddi 1 CD not recognized MAC/DutchFREDDI1: MAC/Dutch CD not recognized

comment:2 Changed 13 years ago by Kirben

Owner: set to Kirben

comment:3 Changed 13 years ago by Kirben

I added the game details to ScummVM SVN, try the next
Macintosh snapshot of ScummVM SVN.

Reports of all unknown versions of demos and full versions
would be helpful. Please post the details of each unknown
version to this bug report.

comment:4 Changed 13 years ago by Kirben

Resolution: fixed
Status: newclosed

comment:5 Changed 13 years ago by SF/daniel9

The game is recognized when added, when started, ScummVM
quits without any message.

The MacosX console contains the following lines:
Using configuration file:
/Users/d/Library/Preferences/ScummVM Preferences
Looking for freddi
Trying to start game 'Freddi Fish 1: The Case of the Missing
Kelp Seeds'
readMAXS(40) failed to read MAXS data!

I have not tried the PC-version as I don't have a PC at
hand.

Using: ScummVM svn 0.10.0svn (2 sept 2006 18:46:19)
On Mac OS X 10.4.7 tried both PPC & Universal versions

comment:6 Changed 13 years ago by SF/daniel9

Status: closednew

comment:7 Changed 13 years ago by Kirben

Resolution: fixed

comment:8 Changed 13 years ago by Kirben

I updated the HE version for the game, please try the
next snapshot of ScummVM SVN and report your results to
this bug report.

comment:9 Changed 13 years ago by SF/daniel9

I tried with the new build: ScummVM 0.10.0SVN (Sept 13 2006
08:36:13) for MacOS X 10.4.7

The consolelog contains these responses:

Using configuration file:
/Users/d/Library/Preferences/ScummVM Preferences
Looking for freddi
Trying to start game 'Freddi Fish 1: The Case of the Missing
Kelp Seeds'
(0:1:0x37): freddi.he3: premature end
(0:1:0x37): freddi.he3: premature end!

Is it possible this error is also caused by the "endian"
problem other games suffer from?

comment:10 Changed 13 years ago by Kirben

Resolution: fixed
Status: newclosed

comment:11 Changed 13 years ago by Kirben

Yes, that error is due to the mouse data failing to load.
The code used to load mouse data isn't endian safe and the
issue is already listed under bug report #1506591.

Note: See TracTickets for help on using tickets.