Opened 18 years ago

Closed 17 years ago

Last modified 17 years ago

#279 closed defect (duplicate)

SAM: Talking

Reported by: (none) Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

I'm using the Spanish floppy version of Sam & Max,
with the latest CVS 5/18/02.
When I connect the wires at the Largest Ball of Twine
on Earth to the telescope, Sam gets zapped (of
course), then says a line and never stops talking. I
can't skip through it with Escape.

Ticket imported from: #557825. Ticket imported from: bugs/279.

Change History (12)

comment:1 by (none), 18 years ago

Logged In: NO

This affects completion of the game! Please fix soon!

comment:2 by (none), 17 years ago

Logged In: NO

Well, I managed to bypass this by hacking ScummVM to stop
a talker every time I press period.

comment:3 by SF/ender, 17 years ago

Unfortunatly I don't have the Spanish version to test this with.

It sounds like a problem with talkDelay being reset before
String.CPP's CHARSET_1 can execute StopTalk.

comment:4 by (none), 17 years ago

Logged In: NO

I removed a line in one of the files so that whenever I press
PERIOD, it stops a talker, like I said. It worked, but then Max
says a line, and never stops talking. I press PERIOD again,
and Sam zaps Max. It works fine after that.

I also remember it happening after Bumpus' performance.

comment:5 by (none), 17 years ago

Logged In: NO

I have the same problem with the English Floppy Version,
using version 0.2.0 for Win32.

comment:6 by fingolfin, 17 years ago

Summary: Sam & Max: TalkingSAM: Talking

comment:7 by fingolfin, 17 years ago

Just for reference: I can't reproduce this problem in the
English talkie with recent CVS. That is, I played thru this
scene two days ago, got zapped, but noticed no problems.

comment:8 by (none), 17 years ago

Logged In: NO

No, this has not been fixed. Please fix it soon!

comment:9 by SF/ender, 17 years ago

Fingolfin: This problem doesn't occur with the talkie at all -
only floppy

comment:10 by (none), 17 years ago

Logged In: NO

I have a crazy uncontrollable feeling it's somehow related to
the electrical sound effects playing.

comment:11 by SF/ender, 17 years ago

This is part of the iMUSE problems, as listed in a seperate bug report.

Closing.

comment:12 by SF/ender, 17 years ago

Owner: set to SF/ender
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.