Opened 13 years ago

Closed 14 months ago

Last modified 9 months ago

#2788 closed defect (fixed)

ALL: Engine creates launcher entry when failing to launch

Reported by: salty-horse Owned by: bgK
Priority: high Component: GUI
Keywords: Cc: raziel_nosgoth@…
Game:

Description

Using current svn.

When launching scummvm with a target name that is not
defined in .scummvmrc, it is searching the current
directory.

When the following targets are not defined, they show a
"game data not found" error, then return to launcher
with new entries created for them:
feeble
simon1
simon2

The SWORD1 engine correctly displays a "files not
found" error, but does not create a new entry. Perhaps
that behaviour can be copied to the Simon engine easily.

Ticket imported from: #1544799. Ticket imported from: bugs/2788.

Change History (22)

comment:1 Changed 13 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:2 Changed 11 years ago by Kirben

Owner: Kirben deleted
Resolution: fixed
Status: closednew

comment:3 Changed 11 years ago by sev-

Does it still occur in SVN?

comment:4 Changed 11 years ago by sev-

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:5 Changed 11 years ago by sev-

Status: newpending

comment:6 Changed 11 years ago by salty-horse

Status: pendingnew

comment:7 Changed 11 years ago by salty-horse

Yes, it still occurs in the latest revision.

comment:8 Changed 11 years ago by sev-

Priority: normalhigh

comment:9 Changed 11 years ago by sev-

Raising priority. This bug is nice to get fixed before the release.

comment:10 Changed 11 years ago by sev-

Owner: set to Kirben

comment:11 Changed 11 years ago by sev-

Raising priority. This bug is nice to get fixed before the release.

comment:12 Changed 11 years ago by Kirben

Owner: Kirben deleted

comment:13 Changed 11 years ago by Kirben

To clarify, the problem occurs with any target this time, and isn't specific to AGOS engine.

I suspect it could be related to merger of detection code in past, but no idea on the exact cause this time around.

comment:14 Changed 11 years ago by salty-horse

Component: Engine: AGOS--Unset--
Game: Simon the Sorcerer 1
Summary: SIMON: Engine creates launcher entry when failing to launchALL: Engine creates launcher entry when failing to launch

comment:15 Changed 11 years ago by salty-horse

The new launcher entry is not saved after quitting, so the bug isn't that bad.

I did some research:
The gameid in the command line is set as the config domain.
base/main.cpp:detectPlugin() then sets the "gameid".

When the game execution fails in runGame(), the launcher appears.
gui/launcher.cpp::updateListing() encounters the new domain. Since it has a gameid but no description, it fetches the default description.

Somewhere after the runGame failure, the domain should be removed.
The problem is, how to differentiate between existing entries (with domains) that failed to launch, and this new "dummy" domain that failed to launch?

comment:16 Changed 10 years ago by sev-

Fixed in SVN.

comment:17 Changed 10 years ago by sev-

Owner: set to sev-
Resolution: fixed
Status: newclosed

comment:18 Changed 15 months ago by bonki

Resolution: fixed
Status: closednew

This doesn't appear to be fixed, possible duplicate in #10334.

comment:19 Changed 15 months ago by bonki

As I understand it, the implemented workaround only works for engines which use the advanced detector so this is still broken for all (?) other engines, including SCUMM.

Do we have to duplicate the workaround for all non-AD engines or can we solve this in a more elegant way? Why do we allow specifying a gameid without --path in the first place? What is supposed to happen in this case?

comment:20 Changed 15 months ago by raziel-

Cc: raziel_nosgoth@… added

comment:21 Changed 14 months ago by bgK

Owner: changed from sev- to bgK
Resolution: fixed
Status: newclosed

This should now be fixed by commit 643ce81cf7.

comment:22 Changed 9 months ago by digitall

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.