Opened 13 years ago

Closed 13 years ago

#2785 closed defect (fixed)

DOTT: crash when USE Stamp with Contract

Reported by: SF/timohepolis Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

Today I tried to solve a puzzle by combining the "Pony
Express stamp" with the "Contract" to get my 2 million
dollars for the diamond.
The instant I USE the stamp on the contract, with
either of the characters, SCUMMVM shuts down instantly.

I tried both things:
1. Use the stamp on contract without signature by prof.
2. Use the stamp on contract with signature by prof.

In both cases scummvm crashes back to desktop!

I´m using scummVM 0.9.0. (win32) and a german retail
version of Dott

Ticket imported from: #1544388. Ticket imported from: bugs/2785.

Change History (7)

comment:1 by fingolfin, 13 years ago

Owner: set to fingolfin

comment:2 by fingolfin, 13 years ago

Try the windows daily build from today, I made a change yesterday which might
affect this issue.

This issue was reported several times in the past years, but so far we never were
able to reproduce it -- I do not doubt that you have the problem, but it's kinda
difficult to fix something when it ain't broken for you :-). Anyway, I hope to
finally have figured out this one, so I am curious whether the latest snapshot will
fix the issue for you...

comment:3 by SF/timohepolis, 13 years ago

YES thats IT!

with the newest daily snapshot (082206)it works very well!
thank you ;)

comment:4 by fingolfin, 13 years ago

Of course that doesn't mean much, since it's in the very nature of this bug to
vanish and re-appear all the time...

Could you go back and try it again with 0.9.0 to see if it "still" crashes with that
version?

comment:5 by SF/timohepolis, 13 years ago

now, re-installed scummVM 0.9.0., it also works very well.
either with contract signed, or without signature.
weird thing...

but thanks for your fast help! now, dott is trhough, i´m
gonna try full throttle ;)

timohepolis

comment:6 by fingolfin, 13 years ago

Resolution: fixed
Status: newclosed
Summary: DOTT crash when USE Stamp with ContractDOTT: crash when USE Stamp with Contract

comment:7 by fingolfin, 13 years ago

Well, maybe may changes helped, or maybe this heisenbug just vanished
temporarily (as it has done so often in the past)...

Note: See TracTickets for help on using tickets.