Opened 13 years ago

Closed 13 years ago

#2784 closed defect (wontfix)

BASS: Doorman Bug

Reported by: SF/syxtem Owned by: joostp
Priority: normal Component: Engine: Sky
Keywords: script Cc:
Game: Beneath a Steel Sky

Description

ScummVM version (scummvm -v):
ScummVM 0.10.0svn (Aug 20 2006 10:57:28)
It's the same with 0.9.0 Release binaries

Bug details, including instructions on reproducing:
It's in the ground level, near to the entrance of St.
James. When you try to speak to the Doorman, the game
crashes with this message:
ERROR: Unknown script command: 24033

Language of game (English, German, ...):
Italian, but with English language it's the same.

Version of game (Talkie, Floppy, ...):
Floppy version

Platform and Compiler (Win32, Linux, ...):
Win32

Ticket imported from: #1543513. Ticket imported from: bugs/2784.

Attachments (1)

SKY-VM.018 (52.2 KB) - added by SF/syxtem 13 years ago.
Save game at the ground level, near the Doorman.

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by SF/syxtem

Attachment: SKY-VM.018 added

Save game at the ground level, near the Doorman.

comment:1 Changed 13 years ago by SF/syxtem

Summary: Doorman BugBASS: Doorman Bug

comment:2 Changed 13 years ago by joostp

Owner: set to joostp
Resolution: wontfix
Status: newclosed

comment:3 Changed 13 years ago by joostp

I can't reproduce this with any of my savegames or the
"section 3" debugger command.

I just had a quick look at the attached savegame, and it's
in a 'broken' state. How did this happen? No idea, you
probably saved on an unfortunate moment when a running
script was processing compact and/or script-data or the file
got corrupted by other means (bad media?).

This problem pops up every so often and to my knowledge
would happen with the original interpreter as well.

"Fixing" this in the engine will be very hard... the only
way I can think of right now is to somehow check certain
parts of the game's state before allowing to save... but
implementing this is very tricky (maybe not even possible)
and not even guaranteed to work in all cases.

Seeing as we only get about 2 of these reports a year and
working around this is a massive amount of work, I'm closing
this as "Won't fix" for now.

As for your particular problem:

You can try 'fixing' your savegame by typing "scriptvar
ref_henri_speech 16386" in the debugger (Ctrl-d) after
loading it. However since the rest of the savegame may
contain weird/undefined data, I'd recommend loading an
earlier savegame and continuing from that if you can instead.

Note: See TracTickets for help on using tickets.