Opened 13 years ago

Closed 11 years ago

#2774 closed defect

PSP: BS1 scrolling sync issue

Reported by: SF/phreeque Owned by: joostp
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

Using scummvm -v0.9.1svn July 30 build, 1.5fw/333Mhz.

Whenever the screen scrolls with the character left
or right, on the right side of the screen (an inch or
two from the screen's right edge) the graphics show a
vertical line all the way down the screen, almost as
if the screen is folded or out of sync. This happens
in any area of the game that doesn't fit on one
screen and uses scrolling. The issue seems subtle
enough at first but then you gradually notice it more
and more each time the screen scrolls and it detracts
from the overall excellent experience. This also
occurred in the early July build (222Mhz).

I've tried playing both the French and English
versions and the result is the same. Both were the
Talkie versions.

I'm using a PSP with firmware 1.5. On a quick
sidenote, at times the cursor will 'stick' and
continually move left even after I've let go of the
analog stick. This isn't an isolated issue with my
PSP unit as I've tried it on two others and had the
same result.

I would have attached a save game file but this issue
occurs as early as the opening cafe scene since you
can scroll the screen to the right towards the alley
and notice the graphical glitch. Thanks for your time.

Ticket imported from: #1536993. Ticket imported from: bugs/2774.

Change History (12)

comment:1 by joostp, 13 years ago

Owner: set to joostp
Summary: BS1 scrolling sync issuePSP: BS1 scrolling sync issue

comment:2 by fingolfin, 12 years ago

Status: newpending

comment:3 by fingolfin, 12 years ago

What is the status of this item?

comment:4 by joostp, 12 years ago

I've confirmed the tearing issue, but have not yet had time to look into it.

No idea about the sticky cursor issue. Does it happen with just BS1? Does it still occur in 0.10.0? Any further info on how to reproduce?

comment:5 by SF/sf-robot, 12 years ago

Status: pendingclosed

comment:6 by SF/sf-robot, 12 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:7 by joostp, 12 years ago

Status: closednew

comment:8 by sev-, 12 years ago

Joost, you reopened it. What is the status of this item?

comment:9 by fingolfin, 11 years ago

Status: newpending

comment:10 by fingolfin, 11 years ago

What is the status of this item?

comment:11 by SF/sf-robot, 11 years ago

Status: pendingclosed

comment:12 by SF/sf-robot, 11 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

Note: See TracTickets for help on using tickets.