Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2764 closed defect (duplicate)

SYMBIAN: FOA crashes in balloon scene

Reported by: SF/slemiz Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

When flying balloon and trying to enter next screen the
game crashes.
Also heard of the same problem in Monkey Island 2 on
the vertical scrolling parts.

Version of scumm is the latest build from anotherguest
found here:
http://anotherguest.k0.se/cvsbuilds/scummvm-060726-SymbianUIQ3_test.sis

Ticket imported from: #1531983. Ticket imported from: bugs/2764.

Attachments (1)

atlantis.s02 (109.2 KB ) - added by SF/slemiz 13 years ago.
Save file in balloon scene (need anotherguest's latest build to work: http://anotherguest.k0.se/cvsbuilds/scummvm-060726-SymbianUIQ3_test.sis)

Download all attachments as: .zip

Change History (7)

by SF/slemiz, 13 years ago

Attachment: atlantis.s02 added

Save file in balloon scene (need anotherguest's latest build to work: http://anotherguest.k0.se/cvsbuilds/scummvm-060726-SymbianUIQ3_test.sis)

comment:1 by fingolfin, 13 years ago

Owner: set to anotherguest
Summary: INDY4 symbian - Crash in balloon sceneSYMBIAN: FOA crashes in balloon scene

comment:2 by fingolfin, 13 years ago

Hm, maybe this is related to bug #1508942: When you were flying the balloon,
sometimes it would draw outside the actual screen, which could potentially lead
to crashes and other oddities, as described here.

So maybe with a newer SVN build (i.e. from today/tomorrow) this works better?

comment:3 by fingolfin, 13 years ago

This bug is likely caused by grabRawScreen() not being implemented properly. See bugs #1513002, #1531983, #1581342, #1594636.
We should first establish that this is indeed the cause; then make sure it is fixed in the SVN trunk. In addition, porters might want to make a 0.9.1a release with
this issue fixed.

comment:4 by SF/glenhawk, 13 years ago

I have also noticed this problem and a similar problem in DOTT. It seems to be whenever there is a
large amount of screen scrolling required.
EG: FOA - ballon goes off screen and there is a rapid scoll to the next part of the map.
DOTT - Laverne wants the human contest to be judged and approaches the judges, screen scrolls right.
DOTT - Hoagie washes the wagon, Storm begins and Franklin appears (I cannot remember a particular
scrolling event for this one)
DOTT - Laverne says to Purple Tentacle, "you and what Army"; Purple says this Army and the screen
scrolls to the right to display the army of purple tentacles.

I will sumbit a fresh post for DOTT and I think I may have the save games to attach. I have not yet
played MI2 but will be soon and can verify the comment above.
I am also trying to find my brothers copy of Full Throttle (THE BEST GAME EVER!!!) and will let you
know if I find any similar problems.

My solution to the problem was to copy my save game to my PC and play through, save the game again
and replace on my mobile.

I am using the latest Symbian S60 V3 version of SCUMMVM (downloaded on Friday 10th November 2006).

comment:5 by fingolfin, 13 years ago

Closed as duplicate of bug #1513002.

comment:6 by fingolfin, 13 years ago

Owner: changed from anotherguest to fingolfin
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.