Opened 16 years ago

Closed 16 years ago

#2761 closed defect (fixed)

ZAK FM-TOWNS: Wrong Screen-Start position in jungle

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Zak McKracken

Description

ScummVM 0.10.0svn (Jul 26 2006 09:07:14) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

In a few jungle scenes (not the other maze levels, just jungle scenes) the screen start position is "wrong". (pictures attached) At least in Lima when entering the jungle it's started way too much left, then starts to scroll into the right position. (See save game, enter jungle) Dunno if it's meant to be that way, but due to the "cut" in the jungle graphics left of Zak it just doesn't look right.

gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1528856. Ticket imported from: bugs/2761.

Attachments (3)

zakTowns.s19 (20.6 KB ) - added by SF/*anonymous 16 years ago.
Wrong start position, enter the jungle
StartPosition2.jpg (51.6 KB ) - added by SF/*anonymous 16 years ago.
Scrolled to the left to soon fit it again
StartPosition.jpg (51.9 KB ) - added by SF/*anonymous 16 years ago.
Screen starts way to the left

Download all attachments as: .zip

Change History (6)

by SF/*anonymous, 16 years ago

Attachment: zakTowns.s19 added

Wrong start position, enter the jungle

by SF/*anonymous, 16 years ago

Attachment: StartPosition2.jpg added

Scrolled to the left to soon fit it again

by SF/*anonymous, 16 years ago

Attachment: StartPosition.jpg added

Screen starts way to the left

comment:1 by Kirben, 16 years ago

I checked the original version of game under Unz emulator, and this glitch doesn't occur. The glitch is definately a ScummVM specific issue too.

comment:2 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:3 by Kirben, 16 years ago

Another regression, caused by the setCameraAt() call been removed from o5_loadRoomWithEgo() in the past.

It is actually required by the FM-TOWNS versions of Loom and Zak McKracken, according to disassembly of original games.

Note: See TracTickets for help on using tickets.