Opened 16 years ago

Closed 16 years ago

#2760 closed defect (fixed)

ZAK FM-TOWNS: Wrong "stripe" in background

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Zak McKracken

Description

ScummVM 0.10.0svn (Jul 25 2006 18:19:52) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

There's a reddish "stripe" in the background at the Egyptian pyramid entrance (pic attached), between Annie and Zak.

Is this also in the original or is it a glitch (cosmetical) in ScummVM?

AmigaOS4, gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1528535. Ticket imported from: bugs/2760.

Attachments (2)

Stripe.jpg (43.6 KB ) - added by SF/*anonymous 16 years ago.
Reddish stripe
zakTowns.s18 (18.9 KB ) - added by SF/*anonymous 16 years ago.
The place where the "stripe" occurs

Download all attachments as: .zip

Change History (5)

by SF/*anonymous, 16 years ago

Attachment: Stripe.jpg added

Reddish stripe

by SF/*anonymous, 16 years ago

Attachment: zakTowns.s18 added

The place where the "stripe" occurs

comment:1 by Kirben, 16 years ago

I checked the original version of game under Unz emulator, and this glitch doesn't occur. The glitch is definately a ScummVM specific issue.

comment:2 by Kirben, 16 years ago

This is actually an extremely old regression, due to roomPalette[] not been used by older 256 colors games in drawStripRaw().

Fixed in ScummVM SVN, use the next snapshot of ScummVM SVN.

comment:3 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.