Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2758 closed defect (fixed)

ZAK FM-TOWNS: Zak walking through altar stone

Reported by: (none) Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

ScummVM 0.10.0svn (Jul 23 2006 15:32:43)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

At Stonehenge, click underneath Annie, so that Zak
will walk down, you'll see that he is drawn slightly
inside the altar stone, pic follows

AmigaOS4, gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1527672. Ticket imported from: bugs/2758.

Attachments (3)

zakTowns.s13 (18.9 KB) - added by SF/*anonymous 13 years ago.
Just walk down (click underneath Annie)
Altar.jpg (37.6 KB) - added by SF/*anonymous 13 years ago.
See the body and feet are IN the stone
Annie.jpg (36.0 KB) - added by SF/*anonymous 13 years ago.
Annie does it too

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by SF/*anonymous

Attachment: zakTowns.s13 added

Just walk down (click underneath Annie)

comment:1 Changed 13 years ago by (none)

Summary: KAK FM-Towns: Zak walking through altar stoneZAK FM-Towns: Zak walking through altar stone

Changed 13 years ago by SF/*anonymous

Attachment: Altar.jpg added

See the body and feet are IN the stone

comment:2 Changed 13 years ago by (none)

Just wanted to add ... Annie does it too

comment:3 Changed 13 years ago by (none)

Only the left part of the altar is affected, the right part
of the stone works as expected.

Changed 13 years ago by SF/*anonymous

Attachment: Annie.jpg added

Annie does it too

comment:4 Changed 13 years ago by lordhoto

Summary: ZAK FM-Towns: Zak walking through altar stoneZAK FM-TOWNS: Zak walking through altar stone

comment:5 Changed 12 years ago by fingolfin

I can reproduce the problem, it's clearly bug in our walk code. Zak is in box 8 at this point, and by clicking below Annie, you tell him to move to box 5. The walk matrix indicates that can be done by going via box 4. Well, Zak does that, but the problem is that instead of leaving box 8 via its left most end (the point closest to box 4, and just left of the altar), he leaves the box *directly*. This results in the wrong behavior.

comment:6 Changed 12 years ago by fingolfin

Fixed in Subversion, next daily build should have the fix.

comment:7 Changed 12 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.