Opened 13 years ago

Closed 12 years ago

#2753 closed defect (fixed)

COMI: Freeze in Chapter VI, rollercoaster

Reported by: SF/rhay Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

ScummVM: v 0.9.0
Game language: English
Version: CD
Platform: Windows XP

Game freezes (no crash). Load savegame, don't do
anything, just wait for LeChuck and then wait until he
fires at you. When Guybrush wants to jump into the car,
the game freezes. This only happens when you jump off
near captain Marley and his mates.

Console log:
Looking for comi
Trying to start game 'The Curse of Monkey Island'
WARNING: IMuseDigital::cloneToFadeOutTrack: Not free
fade track!

Ticket imported from: #1527274. Ticket imported from: bugs/2753.

Attachments (1)

comi.s25 (82.3 KB ) - added by SF/rhay 13 years ago.
Savegame

Download all attachments as: .zip

Change History (10)

by SF/rhay, 13 years ago

Attachment: comi.s25 added

Savegame

comment:1 by SF/rhay, 13 years ago

Summary: Freeze in Chapter VI, rollercoasterCOMI: Freeze in Chapter VI, rollercoaster

comment:2 by eriktorbjorn, 13 years ago

I, too, get the "cloneToFadeOutTrack" warning, but the game
doesn't hang for me.

comment:3 by fingolfin, 13 years ago

See also bug #1624464.

comment:4 by bluegr, 13 years ago

Are you using compressed music/speech by any chance? If yes, it seems to be a problem with music fade out using sound compression. If you're using compressed music/speech, does that behavior occur with uncompressed audio? Refer to bug #1635361

comment:5 by bluegr, 13 years ago

I've just tried this part, using compressed music and speech (MP3 compression). Running ScummVM under Windows XP SP2

I can always reproduce this when I click on Captain Marley when Lechuck is about to fire at Guybrush. ScummVM freezes when Lechuck hits Guybrush with his fire blast, and Guybrush goes "ooh aah" because he's stepping on the fire. The console shows a lot of cloneToFadeOutTrack warnings at that part

I've renamed VOXDISK2.BUN to test this part without speech, and it never crashed without speech.

comment:6 by sev-, 12 years ago

Owner: set to aquadran

comment:7 by bluegr, 12 years ago

As I said, I could always reproduce it when clicking on Captain Marley when Lechuck is about to fire at Guybrush. Patch #1839861 fixed it for me, tried it many times and I couldn't reproduce it - the console threw a couple of cloneToFadeOutTrack warnings, but the game didn't crash. I believe this can be closed

comment:8 by fingolfin, 12 years ago

Owner: changed from aquadran to fingolfin
Resolution: fixed
Status: newclosed

comment:9 by fingolfin, 12 years ago

Patch #1839861 (which should fix this) has been commited to trunk but (not yet?) to 0.11.0, as it is a little bit risky. It hopefully will be in 0.11.1, though

Note: See TracTickets for help on using tickets.