Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2743 closed defect (fixed)

WINCE: Kyrandia 1 SoundFX Problem

Reported by: SF/carolosf Owned by: SF/knakos
Priority: normal Component: Engine: Kyra
Keywords: Cc:
Game: Kyrandia 1

Description

On the Windows CE PocketScummVM 0.9.0:
Some Kyrandia 1, SoundFX don't stop until the music changes

Like when getting the amulet,
or when malcom blows up the tree in the introduction

PC version works fine for me though

Using DOS CD Version of Kyrandia 1

Ticket imported from: #1524183. Ticket imported from: bugs/2743.

Attachments (1)

kyrasavs.zip (26.9 KB ) - added by SF/carolosf 13 years ago.
Kyrandia Save Games to replicate problem + Instructions

Download all attachments as: .zip

Change History (11)

comment:1 by SF/knakos, 13 years ago

Owner: set to SF/knakos

comment:2 by SF/knakos, 13 years ago

Can you please provide a savegame and instructions on how
to reproduce this?

comment:3 by SF/carolosf, 13 years ago

Easiest way to reproduce the problem
Watch the kyrandia introduction
when squirrel jumps on tree
there is an explosion sound effect
the explosion sound does not end until the music changes

comment:4 by eriktorbjorn, 13 years ago

Which music driver are you using? The Kyrandia MIDI
music/sound is known to be broken - it always loops, even
when it shouldn't - while Adlib works with the standard
version of ScummVM. (I don't know if it does with the
Windows CE version.)

comment:5 by fingolfin, 13 years ago

This tracker item is pending response by the submitter; we
cannot continue processing it before that happens. As a
consequence, its status has been set to "Pending". It will
automatically revert to "Open" once a new comment is made to
this item. If no response is made within 14 days, it will
automatically be closed.

Thank you.

comment:6 by fingolfin, 13 years ago

Status: newpending
Summary: WinCE: Kyrandia 1 SoundFX ProblemWINCE: Kyrandia 1 SoundFX Problem

comment:7 by SF/carolosf, 13 years ago

Status: pendingnew

comment:8 by SF/carolosf, 13 years ago

The audio driver was set to default...
I set the driver to Adlib, and the problem is still there...
Tried FM Towns driver too... same thing...

My Windows Mobile Device:
I-Mate PDA2k, WIndows Mobile 2003 SE
CPU: Intel PXA263, 400mhz
Ram size: 128mb
LCD: 240 x 320 65536 colours

Kyrandia Version:
The Legend of Kyrandia (English/DOS/CD)

by SF/carolosf, 13 years ago

Attachment: kyrasavs.zip added

Kyrandia Save Games to replicate problem + Instructions

comment:9 by SF/knakos, 13 years ago

This bug is gone in the gcc 0.10.0svn build (will be up for
downloads shortly). The closest thing I can attribute it is
either wrong emmitted code by the ms compiler (again) or
some midi synth commit which fixed it (haven't verified
this).

comment:10 by SF/knakos, 13 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.