Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2721 closed defect (fixed)

FOA: Crashes when walking to next screen (PSP)

Reported by: SF/fddtieske Owned by: joostp
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

I recently ran into a little problem with ScummVM
0.9.0 on the PSP.
I was playing Fate Of Atlantis (English/DOS-Talkie)
and then when I wanted to go to the next screen the
game freezes and the PSP shuts down.
When I copy the savegame to the PC, I can play
normally from that point with Win32 ScummVM 0.9.0.
I think it happens when you go from one screen to
another screen with a "scrolling" effect. When the
screens sides match. I hope that makes sense.
- It happened for example when you travel with the
balloon or the camel in the desert, as soon as you go
right or down in the first screen.
- Also happens when you go from the "X"-screen (where
your balloon crashes) in the desert to your left to
the german digsite.
- Also happens when you go down the elevator in Crete
ruins where you whip the head of the statue.

(I attached a savegame with the digsite. When I load
this game and walk to the screen to the right, that's
where it crashes on my PSP.)

- I also noticed that on the PSP no screenshot is
saved with the savegame and on the PC it does. (maybe
no support in PSP version?)
- When I press "credits" it rolls the credits, but
when I want to exit the credits by pushing the
button, it freezes and shuts down.

Ticket imported from: #1517798. Ticket imported from: bugs/2721.

Attachments (1)

atlantis.s05 (25.1 KB) - added by SF/fddtieske 13 years ago.
Savegame Digsite

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by SF/fddtieske

Attachment: atlantis.s05 added

Savegame Digsite

comment:1 Changed 13 years ago by Kirben

Summary: Crashes when walking to next screenFOA: Crashes when walking to next screen

comment:2 Changed 13 years ago by Kirben

Owner: set to joostp
Summary: FOA: Crashes when walking to next screenFOA: Crashes when walking to next screen (PSP)

comment:3 Changed 13 years ago by Kirben

Sounds like it could be related to revert of code used for
the scrollEffects in SCUMM engine. Maybe moveScreen()
function has issues in PSP port?

comment:4 Changed 13 years ago by joostp

Resolution: fixed
Status: newclosed

comment:5 Changed 13 years ago by joostp

This was indeed caused by that change.
The new (or should I say 'old') implementation uses
grabRawScreen(), which wasn't implemented on the PSP.
So the assert() in ScummEngine::moveScreen() would trigger.

This is now fixed in SVN (both trunk and the 0-9-0 branch)
and also fixes the thumbnail not being saved in the savegame.
I also made grabRawScreen() in the OSystem class pure
virtual so other backends that don't have grabRawScreen()
implemented don't accidentally run into the problem again.

I can reproduce the credits crash in the 0.9.0 release, but
not in my fresh build, so I'll forget about it for now.

Thanks for reporting and thanks Kirben for the valuable comment.

comment:6 Changed 13 years ago by SF/fddtieske

Thanx for the quick response and the fix!!
Don't know if I can build it myself from the source, so
I'll probably wait for the next release!
Thanx again.

Note: See TracTickets for help on using tickets.